cancel
Showing results for 
Search instead for 
Did you mean: 

Help with connection/speed

suniokera
Joining in

Just installed virgin broadband 108Mbps M100 fibre, it works fine in the living room where the router is but in bedrooms a little further there is no connection or super slow.

My question: Will this problem be solved if I upgrade to M200 fibre and 213Mbps?

Or do I solve it with an extender?

Or does it help to switch provider? i currently have virgin media trial.

Help please

We are three people sharing the flat.

4 REPLIES 4

Adduxi
Very Insightful Person
Very Insightful Person

Absolutely do NOT upgrade your speed to solve a Wifi problem !!!

The VM solution is to use Wifi Pods, and on your Tier, it's £8pm for up to 3 Pods.  See this link https://www.virginmedia.com/help/wifi-max

However, you can buy your own extenders or Mesh solution and this would be yours to keep irrespective of ISP.

It's up to you at on how you proceed.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Client62
Hero

How odd for a first post to be about M100 and M200 & to mention the old service speeds.

legacy1
Alessandro Volta

Buy this put hub in modem mode

ZYXEL - SOHO NBG7510 AX1800 WIFI 6 ROUTER : Amazon.co.uk: Computers & Accessories

---------------------------------------------------------------

Kath_F
Forum Team
Forum Team

Hi suniokera, 

Thanks for taking the time to contact us via the Community. It's lovely having you on board with us in the Forums.

We're sorry to hear you're having some issues with your WiFi connection. Upgrading the speed won't help with the signal itself so for now, I would advise against doing this. 

There are so many things that can influence a WiFi connection some of which include but are not limited to, a fish tank being in the same room, walls being built with concrete instead of brick, it could even be that your next door neighbours router is interfering with yours. Due to this, we are only able to offer limited help. Please have a look here.

The Hub's location could also be causing the coverage problem so we do need to check the positioning of it. Can you please ensure the following: 

  • > Out in the open
  • > Next to the TV not behind it
  • > Away from large bodies of water (e.g. fish tanks)
  • > Away from baby monitors and cordless phones
  • > Away from microwaves

Think of the Hub as a radio, and WiFi as the sound - the further away you are from the radio, or the more obstacles that are in the way (walls, electronic devices etc.), the quieter the radio & the poorer the WiFi. 

If that doesn't help, you can download our Connect App which will allow you to scan areas of your home and will offer help. If a WiFi Pod will help, the app will give you the option of adding this. You can view more information on that here.

Keep us posted on how things go and if you need further assistance, you know where we are. 

Thanks, 

Kath_F
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs