Showing results for 
Search instead for 
Did you mean: 

HUB 4, GIG1 not full speed unless plugged direct from modem


Installed the HUB4 today with gig1.

Speeds direct from the modem on my PC are as advertised 900Mbps+

full speed.png

When I detatch the rj45 from the modem and plug the same rj45 it into my Asus Nighthawk X6 R8000 Router,.which has 4x gigabit ports, i get around 350Mbps.


not full speed.png

Can anyone explain why this huge drop in speed?
I'm thinking it could be one of the rj45 cables are not 1gig spec, not cat6 or higher.
The cable from the modem to the asus router is cat5e on inspection.
The cable from the asus router to my pc is cat6.
Would a cat5e cable give 350+ speeds and not the full 1gig?


Very Insightful Person
Very Insightful Person

Cat 5e is capable of 1GB speeds. Cat6a is just better shielded against noise. Both can be up to 100 metres long. Anything over Cat6a is a waste of money. 
Check that the ASUs is not running QOS as this will reduce the throughput. 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Community elder

Ensure you disable any traffic management (QOS) on the Asus.

Alessandro Volta

@hotfuzzybody wrote:

my Asus Nighthawk X6 R8000 Router,

Do you know if its a Asus or Netgear😋


Thanks for your reply.

QoS is NOT enabled, never has been either.

no qos.png

IDK why i got Asus stuck in my head, I do have Asus monitors and motherboards and the last time I needed to login to the router was a LONG time ago.

Yes, it's a Netgear Nighthawk X6 R8000 that I've had for many years.

As above, I have never enabled QoS in any scenario at any point in time.

I have a R8000 and get full 940Mpbs speeds to it from the hub.

There was some dodgy firmware that caused similar issues on the Nighthawk so is worth checking the firmware is up to date and then doing a factory reset on the Nighthawk.

@hotfuzzybody wrote:
As above, I have never enabled QoS in any scenario at any point in time.


1.2Gb/100Mb in Oxford (area 31) using SH5

@hotfuzzybody wrote:
As above, I have never enabled QoS in any scenario at any point in time.

Try this site to be sure it isn't an issue with the specific site you are using:


OVHcloud results.png

The "specific site" doesn't have issues. As previously stated, if I plug the PC direct to the hub4 I get full 1Gig speed as displayed from app.
It is when I change the hub4 into modem mode only and plug that into the Netgear Nighthawk router that I get the issues of a capped speed.
Note I have now changed all cables to cat6 with identical results of being capped.

I have tried to enable QoS and "Let Speedtest detect my Internet bandwidth" resulting in (and yes during the speed tests, no other device is plugged in or using wifi):

QoS speed detection.png

I have tried to "define my internet Bandwidth" but it has refuses to accept the values and when it does accept them after clicking the "apply" button, nothing changes and the speed is still capped, with QoS enabled or not. Actually when QoS is enabled and I put my PC on the highest priority it is around 150Mbits maximum. QoS doesn't work efficiently.
Interesting why it shows 417Mbits.


When I plug everything else in and use wifi (real world scenario) it shows that I get 1000M/Full on the rj45 ports.

router stats.png

I have tried to factory reset the router, but alas this broke even more and was lucky enough to save a backup config of the router.