cancel
Showing results for 
Search instead for 
Did you mean: 

Gig1 speeds very slow over ethernet

SilentMatty
Joining in

Hi there,

I purchased virgin media gig1 internet around a month ago and the download speeds over ethernet have been pathetic. I am getting 90mbps on samknows realspeed. I contacted  customer support and they told me it's an issue with my device - this is not true as other devices experience same issue. They also told me that my computer must not support gigabit connection - also not true, I have a motherboard which does support and also purchased a gigabit ethernet card (now £10 out of pocket!) thinking it would fix the issue  - it made no point.

Customer services have promised me twice they would raise the issue, never heard anything back. The second time I called up I was ensured I would be called back within the hour by a manager - this was 2 weeks ago and heard nothing back.

Over wifi I get 600mbps on samknows but all ethernet devices receive around 90. Virgin are refusing to help.

I have tried:

Pinhole Reset

Regular turning off router

4 different cat 5e/6 ethernet cables

multiple devices

starting main PC in safemode

Thank you!

10 REPLIES 10

Client62
Legend

getting 90mbps on samknows realspeed   ( at the device ) - I would agree that is a 100Mb/s network connection.

Typically this is caused by crossing a network device such as a 10/100 switch or Power line extender.

Or a faulty network cable that is de-rating the connection from 1000 to 100Mb/s

Or a network card that is set to 100Mb/s (not Auto) or a driver that does not support 1000 Mb/s.

Or a 10/100 USB to Ethernet adaptor or NIC.

Regardless it is normally possible to see the 100Mb/s connection in Hub Connected device list and / or via the computer's network status info.

 

carl_pearce
Community elder

It's also been reported as faulty HUB 5s.

speedtest.net shows 427.79

fast.com hard caps at 220

Oh really? Virgin were refusing to send me another Hub 5....

Try the 2.5Gbps port on the HUB 5.

Yes this is what I was trying, tried 4 different cables 🙂

SilentMatty
Joining in

SilentMatty_0-1691853933589.png

Here is my samknows results

Yes, certainly looks like you are limited to 10/100 Ethernet speed.

Have you tried all ports on the HUB?

Feels like a faulty HUB.

Tried all the ports, technician came out and tried his device, as well as another hub and ethernet cable and no solution. They say they don't know what the issue is and can't help because the hub is getting the correct speed just not outputting to ANY device. The other hub was the same too. Really not sure what to do 😞