Menu
Reply
SkipperOdyssey
  • 24
  • 0
  • 2
On our wavelength
369 Views
Message 1 of 4
Flag for a moderator

False promises - appalling Customer Support

So I have been with Virgin for some time now and have never received the promised speeds.

The area I live in is a fairly new development and Virgin laid cable around 2 years ago.

Since then, I have paid for speeds of 600Mbps of which I never got and now I upgraded to 1GB courtesy of the VOLT deal.

I have been waiting 2 - 3 weeks to find out when Virgin Media are going to get around to fixing my issue or at least contact me and stop promising what they are unable to do.  My max speeds when connected by Ethernet Cable are 400mbps.  The Ethernet cable is CAT6.  I am a techie and know what I doing.

Every time I call them I either have to run through the basic fault finding EVERY time and then promised a support engineer would contact me but this never happens.  I call up and the system tells me an engineer is on his way but not according to the call handler!? 

I am so sick and tired of going around in circles!

Virgin, please investigate my issue urgently.  You have already told me that there is an issue and the "24 hour" response you also promised me is now over 2 weeks.

I called you at around 11am today after expecting you to call me as arranged at 1030hrs which never happened.  I was told that again someone would contact me within minutes and this never happened.  I later get a call from Virgin Media to see if I wanted to buy an iPhone 13?????

Please sort it out and I look forward to hearing from you soon and a fix.

Tags (1)
0 Kudos
Reply
jb66
  • 12.96K
  • 987
  • 1.94K
Very Insightful Person
Very Insightful Person
352 Views
Message 2 of 4
Flag for a moderator

Re: False promises - appalling Customer Support

Can you post a speed test from here...

https://www.samknows.com/realspeed/

0 Kudos
Reply
SkipperOdyssey
  • 24
  • 0
  • 2
On our wavelength
343 Views
Message 3 of 4
Flag for a moderator

Re: False promises - appalling Customer Support

Hi,

I would but the Router is now back in Modem mode as I use a Ubiquiti Pro 4 USG which is in another room etc.  I need a working environment for tomorrow so can't do this again now sadly.

SkipperOdyssey_0-1637511208501.png

The above shows the speed on the external interface of the USG.

I have around the same speeds using the Hub 4 in Router Mode and Windows 10 in Safe Mode with networking and the router connected directly to the cable as it comes in to the house.  The NIC on the laptop is a 1GB Nic.  As I say Virgin have already confirmed there was an issue but don't appear to be doing anything about it.

Thanks for your help. 

 

0 Kudos
Reply
Martin_N
  • 8.33K
  • 351
  • 510
Forum Team
Forum Team
222 Views
Message 4 of 4
Flag for a moderator

Re: False promises - appalling Customer Support

Hi SkipperOdyssey,

Thank you for your post. 

I'm very sorry to hear about the issue with your broadband. 

I have been able to locate your account and taken a look at your levels. 

From what I can see there are some error that a technician visit would be required to resolved. 

What I will do is private message you to pass some data protection and look to get a visit booked in.

^Martin

0 Kudos
Reply