Menu
Reply
JSD2
  • 2
  • 0
  • 0
Joining in
208 Views
Message 1 of 8
Flag for a moderator

wrong power cable sent with hub

Just received my hub 4 pack today with the wrong power cable!!! Customer service saying will take 3-5 days for correct one to be sent out. Not good enough as I'll be without internet connection until it arrives. Not convenient as we're working from home, for which internet connection is essential. Also customer asset unable to provide spec for cable, meaning I can't even order one from Amazon or something meantime!! Anyone know the specs if the power cable for the Hub 4 and/or where I can get one preferably next day delivery? 

0 Kudos
Reply
-tony-
  • 16.92K
  • 1.32K
  • 4K
Very Insightful Person
Very Insightful Person
163 Views
Message 2 of 8
Flag for a moderator

Re: wrong power cable sent with hub

what have they sent - hub4 is a 'brick' power adaptor and a figure of 8 power cable - the cable is standard - used on many things - if thats all you are missing thne its nothing special - however if its the power supply then  you need to wait for the correct one

is this a new install or do you have an earlier hub - afaik the mains adaptor from the hub3 fits the hub4

____________________

Tony
0 Kudos
Reply
JSD2
  • 2
  • 0
  • 0
Joining in
126 Views
Message 3 of 8
Flag for a moderator

Re: wrong power cable sent with hub

Hi Tony thanks for replying. It's the power supply that doesn't fit. We have the hub 3 and it doesn't fit either. Really need internet access so we can work from home. Earliest they can send out an engineer with the correct power supply is Thursday!! 

0 Kudos
Reply
-tony-
  • 16.92K
  • 1.32K
  • 4K
Very Insightful Person
Very Insightful Person
122 Views
Message 4 of 8
Flag for a moderator

Re: wrong power cable sent with hub

there have been posts before that some power supplies do not fit - not sure if something has changed or its simply a wrong component

if you have a working hub3 has that been de activated from your account or is it an old one prom elsewhere

either way they may re activate it if you push hard - its never easy but try not to take no for an answer

dial 150 or 0345 454 1111 and follow the prompts to - 'thinking of leaving us'  - dont worry about that they do much more - open 8am -10pm 7 days a week - should take you to a UK call centre

____________________

Tony
0 Kudos
Reply
Tomgeo123
  • 3
  • 0
  • 0
Tuning in
66 Views
Message 5 of 8
Flag for a moderator

Re: wrong power cable sent with hub

I've had the exact same issue (received hub4 on saturday) and after waiting for 4 days for the new power supply to arrive they sent me a new TiVo remote...I hope you have better luck than me! I'm now waiting to see what my next suprise package contains.

0 Kudos
Reply
Gareth_L
  • 6.89K
  • 423
  • 778
Forum Team
Forum Team
49 Views
Message 6 of 8
Flag for a moderator

Re: wrong power cable sent with hub

Hello Tomgeo123

Sorry to hear that has happened 

Can you please let us know when you ordered the power supply

If its easier I can see if we can get a tech to pop one through your letter box

Gareth_L

Tomgeo123
  • 3
  • 0
  • 0
Tuning in
35 Views
Message 7 of 8
Flag for a moderator

Re: wrong power cable sent with hub

Hi Gareth,

I ordered it on Thursday.

Would be great if a tech could do that! Thanks

 

0 Kudos
Reply
Robert_P
  • 2.94K
  • 150
  • 269
Forum Team
Forum Team
27 Views
Message 8 of 8
Flag for a moderator

Re: wrong power cable sent with hub

It can take up to 5 working days for these to be received Tomgeo123 but I'm eager to make sure the order has been completed. I'm going to send you a Private Message to get some more details from you to look into this.

 

Looking forward to hearing back form you.

 

Rob

0 Kudos
Reply