Showing results for 
Search instead for 
Did you mean: 

Virgin connect not identifying hub 5

Joining in

I have tried all the suggestions. I’m connected to it through wifi and it still doesn’t work. It’s not in modem mode and there’s no equipment connected to it. I can connect to the hub via my laptop and it says everything is ok. 
I really need wifi pods because the wifi doesn’t reach my home office. Any other way to order them?


Forum Team
Forum Team

Hi adamgpol,

Thanks for your post, welcome to the Community Forums!

I'm sorry to hear you've been having some trouble with your connection. Are you experiencing issues connecting to your Hub across multiple devices, and over wired and wireless connections?

What error message are you receiving on the devices that aren't receiving an internet connection?

In regards to your home WiFi coverage, we have some great tips on how to improve this here. We'd also recommend to download our Connect App which will allow you to scan your home for WiFi black spots. Advice will the be offered on how to improve your coverage around the home based on the scan results, and you will be able to order WiFi pods from there if we find that they will benefit your connection.

Hope this helps!



From your mobile check the Hub's menu can be reached at

If the menu can not be reached from the mobile, disable all forms of Apple Private Browsing / VPNs and try again.

If the Hub's menu can be reached from the mobile, the VM back end has not updated to reflect the Hub 5 that you are using and all that you can to is try again in a few days to a week.