Showing results for 
Search instead for 
Did you mean: 

VM Connect App

Tuning in


I set up my hub 4 yesterday and everything is fine, all devices in the house are connected and apart from one room in the house that requires a booster the WiFi seems ok. The only issue is I cannot, for the life in me, connect to the VM connect app. It just constantly tells me it can’t find the hub despite me being right next to it when trying to set it up. I have tried rebooting the hub, doing a har reset, deleting and reinstalling the app all to no avail. I am connected to VM WiFi when I am trying to do it and still nothing. Any help would be greatly appreciated!!!


Very Insightful Person
Very Insightful Person

Hi @AmyJ1 

The Connect app for iphone now works with the hub 4  - The latest version, 12.28.18 was only released on Thursday. If you are on IOS you can force the latest version by going to the app store.

The android version is being updated in stages, however on android there is no way to force it, but any android owners should get it by the 12th Sept

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali


thank you for the reply, I happened to click on this afternoon and low and behold it had connected to the hub and all is well, thank you for your help 🙂 

Hi @AmyJ1

Welcome to the community. 

Sorry to hear you had some connection issues with the Connect App. Glad to hear that this has now been resolved for you. Please let us know if you have any further questions or concerns, we'll be here to help if needed 🙂

Here to help 🙂
Virgin Media Forums Agent