Menu
Reply
Highlighted
  • 10
  • 0
  • 0
Joining in
305 Views
Message 1 of 19
Flag for a moderator

Superhub 3 losing DHCP IP Reservations

I reserve IP addresses on my Superhub 3 mainly for printers, my work equipment and our data sources.

When I can see the reservation is there it works perfectly. However, if I don't use the device (mainly for example my printer) for a few days then I notice the hub loses the reservation. I can work around this as when printing doesn't work, I just go in and ensure the reservation is there and restart the printer.

Setting the address manually has led to IP conflicts so I can't do that. What I'm wondering is if there is a time limit on reservations or a fault in the hub design that means it loses the reservations after a period of time if they are not used?

I don't know if this is permanent, but one fix I thought of is change the starting allocated IP for new connections to be above the reserved addresses. That way if this isn't lost as it shouldn't be then I can set manual IP addresses instead for rarely used equipment and it should all just work normally.

0 Kudos
Reply
Highlighted
  • 20.96K
  • 1.13K
  • 2.7K
Alessandro Volta
298 Views
Message 2 of 19
Flag for a moderator

Re: Superhub 3 losing DHCP IP Reservations

I hard set my device IP’s on the devices themselves have no issues with conflicts and i have 30+ devices connected all with hard set IP’s. 


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
0 Kudos
Reply
Highlighted
  • 10
  • 0
  • 0
Joining in
294 Views
Message 3 of 19
Flag for a moderator

Re: Superhub 3 losing DHCP IP Reservations

I have had conflicts though and it's a pain to fix if you can't connect and find out what's happening as in what device is causing it. Though switch off anything with static IP and you can fix.

This is the reason why reservations are normally on business networks put in a different range which is kept for reserved IP addresses. On this hub, the only way I can do that (which I haven't tested yet) is to set the hub to start allocating IP addresses above the reserved range. So for example, set it to allocate from 192.168.0.40 instead of 192.168.0.10 which it does at present.

I'd prefer the hub just kept my reservations though which it isn't doing for rarely used items and it is annoying.

0 Kudos
Reply
Highlighted
  • 20.96K
  • 1.13K
  • 2.7K
Alessandro Volta
291 Views
Message 4 of 19
Flag for a moderator

Re: Superhub 3 losing DHCP IP Reservations

Put it in modem mode and get a router that has more reliable firmware and features. 


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
0 Kudos
Reply
Highlighted
  • 10
  • 0
  • 0
Joining in
287 Views
Message 5 of 19
Flag for a moderator

Re: Superhub 3 losing DHCP IP Reservations

Well yes of course but I'd like to fix the Virgin Media supplied router or work with it somehow for a permanent solution.

0 Kudos
Reply
Highlighted
  • 2.06K
  • 127
  • 401
Problem sorter
278 Views
Message 6 of 19
Flag for a moderator

Re: Superhub 3 losing DHCP IP Reservations

Static IP address should be outside the DHCP range, so that will work. It's more of a concern that the Reserved DHCP leases are removing themselves.? I've not come across this complaint before in the Forums.

Are you sure you are setting Reservations, and not just looking at the current DHCP leases?  These are not reserved, but only what's in use at the time.  If a piece of kit is off, then DHCP will release that IP address back to the pool. So the next time the kit is on, it may not get the same IP address, unless it's specifically set as a Reserved DHCP Lease.

0 Kudos
Reply
Highlighted
  • 20.96K
  • 1.13K
  • 2.7K
Alessandro Volta
277 Views
Message 7 of 19
Flag for a moderator

Re: Superhub 3 losing DHCP IP Reservations

You can try factory resetting the hub then trying again.


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
0 Kudos
Reply
Highlighted
  • 10
  • 0
  • 0
Joining in
264 Views
Message 8 of 19
Flag for a moderator

Re: Superhub 3 losing DHCP IP Reservations

Definitely setting them and one reason to be sure I know this is that it happened this morning with my printer. Switched it off and back on and it picked up the reservation again.

Agree they should be outside a range that's available for selection but the router should be permanently reserving those addresses.

I have a TP-Link router that's DD-WRT compatible so might be using that in router mode long term, just don't have the time to sort it yet. Would still like to fix this problem and stop the router losing reservations. I don't want to have to switch to manual/static setting but sounds like I might have to and move the available starting address up to accommodate this.

0 Kudos
Reply
Highlighted
  • 2.06K
  • 127
  • 401
Problem sorter
241 Views
Message 9 of 19
Flag for a moderator

Re: Superhub 3 losing DHCP IP Reservations

Yes, sound like something is amiss. I use Reserved DHCP at home on my Draytek and it's always been okay. Personally DD-WRT would be the way forward 🙂
0 Kudos
Reply
Highlighted
  • 2.19K
  • 92
  • 437
Problem sorter
230 Views
Message 10 of 19
Flag for a moderator

Re: Superhub 3 losing DHCP IP Reservations

"I have had conflicts though"

I mean unless you're running 200 devices on your network, which you really shouldn't be doing in the first place on an ISP supplied router, you just set static IP's in ranges you know are never going to get used

start with 192.168.0.200 and go from there and its super easy to avoid any potential conflicts at all

0 Kudos
Reply