Showing results for 
Search instead for 
Did you mean: 

Struggling to get Hub 5 into Modem Mode with my Draytek Router.

Joining in

I'm trying to put my Hub 5 into modem mode to avoid double routing with my Draytek.  It works fine with the Hub in router mode - the Draytek gets its IP address from the Hub (192.168.0.xx).  However, when I change the Hub to modem mode, the Draytek won't get an IP address. 

If I plug the Hub into my laptop when in modem mode, the external IP address is assigned to the laptop so I know the Hub is successfully in modem mode.  The Draytek is in "obtain an IP address automatically" mode since that's the way it gets an IP address when the hub is in router mode, but when I switch the hub to modem mode, the Draytek isn't getting the external IP address. 

I've tried to turn the Hub and the Draytek on in various order, but so far no success.  Again - everything works perfectly in router mode but not in modem mode.

Any thoughts?  I've read various messages about doing things in the right order, but so far no success.


Forum Team (Retired)
Forum Team (Retired)

I don't have a draytek or a HUB5 so your mileage may vary.

I am running PFsense and the boot order for me is to FULLY boot up PFsense before switching on the hub. 

Can you manually choose a gateway on your router and if so what's it set to? 


I work for Virgin Media - but all opinions posted here are my own

Not sure what you mean by manual gateway. I can specify an IP address for the router, a subnet mask and a gateway, but I don't have that option enabled.  I have "Obtain an IP address automatically" enabled. 

There is an option on the automatic IP address for a username/password for gateway server.  That's not enabled and I don't think you need to log in.  When I connected the hub in modem mode to my laptop, it gave me the external IP address with no login.



Very Insightful Person
Very Insightful Person

Modem mode must be done in this sequence the first time:

How to put a VM hub into modem mode:

1) Access your hub on, sign on and put it into modem mode. On the Hub3 the bottom LED will change to magenta. Best done from a wired connection.

2) Turn off the hub and disconnect any Ethernet cables

3) Fully initialise your own router or mesh master unit and make sure the WAN port is set to DHCP

4) Connect your router or mesh master unit to the VM hub with an Ethernet cable, Cat5e or Cat6, any higher specification is a waste of money

5) Turn on the VM hub.

6) You should now be able to access the internet and the hub will now be on

Note: this only needs doing once for each new router or VM changes your WAN IP address.

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

Very Insightful Person
Very Insightful Person

I have a Draytek 2860 and a Hub 5 in modem mode and it's working fine, so it's not the Draytek.   As @Tudor says, the order of powering on is important for the initial time.

I assume you only have one ethernet cable connected to the Hub in modem mode ?  Can you reset the Draytek to factory settings and try again.?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Is the access mode set to "Dynamic IP"? It must not be PPPoE or PPPoA as that's for DSL broadband.

Hub 3.0, TP-Link Archer C8, TP-Link TL-SG108S 8-port gigabit switch, V6
My Broadband Ping - Roger's VM broadband connection

I can't put the Draytek back to factory settings without my IT guys.  There was a lot of config in the Draytek.  

However, everything is back working with the Hub in router mode and I'm not sure how much performance I'm giving up by having the Hub in router rather than modem mode.

Yes - it's in Static or Dynamic IP mode.  That's how I also get the IP address from the Hub when it's in Router mode.



I did it exactly in this order and still no luck.

The hub is back in router mode and working fine.  Any idea of how much performance is being sacrificed on the hub 5 because it's in router mode?  I've also put the connection to the Draytek in port 4 which is the 2.5GB port.

One thing I think I might throw into the pot, but I dunno!!

The laptop'll pick up a different address from the outside because it's the client MAC that gives you the DHCP lease from VM.. (I've had the same address through different modems for several years)

I'd try (and I'm just a good fiddler)

Can you set the Draytek WAN mac address to the same as the laptop, and change the laptop's just to be sure... Could it be you're trying to pick up 2 addresses and you're only allowed one.? 

I know my IP from heart I've had it that long! 🙂