Menu
Reply
Highlighted
  • 2
  • 0
  • 0
Joining in
281 Views
Message 1 of 4
Flag for a moderator

Sonos speakers

  • I’ve just had virgin broadband and tv installed. But I can’t get it to connect to my Sonos speakers. Any insights or technical help greatly appreciated 
0 Kudos
Reply
Highlighted
  • 15.74K
  • 1.65K
  • 2.69K
Very Insightful Person
Very Insightful Person
275 Views
Message 2 of 4
Flag for a moderator
Helpful Answer

Re: Sonos speakers

Mine works perfectly but I have my own wifi equipment.
You could try the below, it ought to sort it - but you will need to go and reconnect all your wifi kit.

Go into the Hub3 settings. Type in http://192.168.0.1 into your web browser’s url box and login with settings password on the Hub's base sticker (or your own if you changed it). Then in Advanced>wireless>smart wifi - tick the disable “channel optimisation” box and save settings. Then, go to advanced>wireless>security, rename the 2.4 & 5 GHz network ssid's. Just change 'em to whatever you like and something that will differentiate them (e.g - margo2 & margo5) -- use the same password if you like, Then, apply settings and restart the Hub. Your 2 wifi networks will now be clearly separated - and you can then select the network you want to connect to individually from the "available networks" list on each device. 5 GHz is usually better and subject to less interference (and is better for iDevices ) than the 2.4 one - although this one has the better "range" and some older/cheaper/dumber devices can only use this one.
My Sonos's are on the 5GHz band.

You should also use a wifi analyser App to check which 2.4 channels are being heavily used around you and move yours to one of numbers 1,6,11 that is least so.

See if that helps - you will lose any “seamless roaming” benefits but it may not matter and you can always change the settings back or do a "factory reset" if you prefer the way it was - or it doesn’t help.

--------------------
John
--------------------

My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
Highlighted
  • 207
  • 8
  • 20
Superfast
257 Views
Message 3 of 4
Flag for a moderator
Helpful Answer

Re: Sonos speakers

Have you turned the Sonos speakers off/on to allow them to connect to your new broadband?

 

You could also try this link https://support.sonos.com/s/article/1061?language=en_US 

0 Kudos
Reply
Highlighted
  • 2
  • 0
  • 0
Joining in
239 Views
Message 4 of 4
Flag for a moderator

Re: Sonos speakers

Thank you so much John and Simon, it took a while but I went through all the steps and then turned the speakers off and the on. I now have a Margo 2 and Margo 5 wifi setting and Sonos works!

0 Kudos
Reply