cancel
Showing results for 
Search instead for 
Did you mean: 

So far so awful

Howbadcanyoube
Joining in

My partner and I moved into a new flat together three weeks ago, thankfully I had the foresight to get the Virgin account setup and get the ball rolling a week before we moved in so we’d have internet asap! 
  That’s what I wish i were saying right now… but no here I stand after having been lied to by someone at virgin and now having to wait AGAIN for internet here. 
  Let me explain, firstly we needed a faceplate installation, no problem you’d think so that was booked for the 5th, a nice gentleman showed up three days early saying he was already in the building and had time so he offered to fit it early, I thought great! He “fitted it” in the sense he left it hanging off the wall AND hadn’t done the work needed for it to actually connect me.. I find out today, the day the engineer was supposed to connect me up and I’d finally be able to get online. Now the day he put the plate on I called up Virgin and they informed me someone was supposed to come finish the job on the 8th, no show. They also informed me they’d send out a quick start kit to get me connected earlier since the plate had been fitted early, I’d find out on a later call that this was not the case and nothing, especially the appointment to fix the plate on the 8th had been done. Nobody seemed to know what the hell they were doing. 

So now, the engineer has just left with the router and any hope my partner and I had of actually using the internet today or indeed anytime soon. She said she’ll get the plate fix appointment sorted out and then they’ll have to book me another appointment for another engineer to come out and get me online.

We’re completely out of energy for this, every turn Virgin has done something wrong and I don’t even know if I want to stick with you guys because I have no idea now how long it’s going to be before we actually are able to use the internet we both rely on for many things…

1 REPLY 1

Reece_MH
Forum Team (Retired)
Forum Team (Retired)

Hi there 👋

Thanks for posting, and a warm welcome to the Community Forums.

I'm sorry to hear about this experience with your installation, and that you still do not have a working service. I've taken a look at things on our side and can see you spoke with our team since posting, and they have been able to assist further with this and provide further information.

Please do let us know if there's anything else we can assist with, and we'll do our best to help out.

Cheers,

Reece - Forum Team


New around here? To find out more about the Community check out our FAQ