Showing results for 
Search instead for 
Did you mean: 

Ring door bell

Joining in

Hi all 

I have seen posts re ring door bell connection issues and have tried all the suggestions on here .

My ring door bell does not connect to virgin media hub 3 so frustrated , no issues with my other provider please could someone help 


Very Insightful Person
Very Insightful Person

If you have not got pods, go into the settings on your hub and split the SSIDs, so they are named xxx-2 and xxx-5. Then connect the device to the xxx-2 band. Also turn off smart/intelligent WiFi. 

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

Hi I've have split these into 2.4 and 5 and renamed then as suggested and turned of intelligent .

Still no luck

Alessandro Volta

The Virgin Hubs don't have wonderfully strong WiFi.  Is yours in a clear open place, not tucked behind any obstructions?

I've had the door bell sitting on top of the hub still no luck .

I was wondering if the doorbell can be manually configured to the router? 

Alessandro Volta

Well done, that was my next suggestion to try!   I assume you've tried resetting the bell by removing its battery. I think you might get better answers to the manual setting on the Ring support site.

Yes I've tried removing the battery and fully charging it. It just seems to be a problem connecting to virgin , why are they different to every other supplier ?

Alessandro Volta

Google will find several threads that might help, like this one

Hi @Mcrawf12,

Welcome to our Community Forums and thanks for your post. 

I am sorry to hear you're having some connection issues with your ring doorbell. 

Are you having any issues with any other devices and could you confirm if you have tried resetting the doorbell?

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Alessandro Volta

If you really want that ring door bell to work get your own wifi router with 1Gb ports and put the hub in modem mode.