Menu
Reply
Davesunley
  • 12
  • 0
  • 0
On our wavelength
149 Views
Message 1 of 3
Flag for a moderator

Recently upgraded broadband and not showing up on account

Hi all I have recently upgraded my package and got told my speed had been increased. Also got told I would be sent a new router at the start of the week which I haven't received I have rung customer service and got told the order was on there for the router so should receive it and also my speed is upgraded. However when I log in my speed package is still the same as it was and also in the track orders section nothing is showing up for the router. Can anyone help at all as don't really want to have to ring up and be stuck on hold again. 

0 Kudos
Reply
Emma_C
  • 8.28K
  • 511
  • 549
Forum Team
Forum Team
103 Views
Message 2 of 3
Flag for a moderator

Re: Recently upgraded broadband and not showing up on account

Hi Davesunley, 

Very sorry that you've been waiting for your new hub and speeds to increase, I do apologise for the delay. 

I can see that since posting this has arrived and should now be up and running for you. 

Can you confirm this is the case? 

Have the speeds increased since getting the new hub? 

Keep us posted. 

Emma_C - Forum Team
0 Kudos
Reply
Davesunley
  • 12
  • 0
  • 0
On our wavelength
52 Views
Message 3 of 3
Flag for a moderator

Re: Recently upgraded broadband and not showing up on account

Hi Emma 

Yes this has been sorted now since the hub arrived the speed and reliability are a lot better thankyou

 

0 Kudos
Reply