Menu
Reply
arvind74
  • 2
  • 0
  • 0
Joining in
157 Views
Message 1 of 3
Flag for a moderator

No broadband...help needed

Just joined for broadband, switchover was Monday with quickstart..but nothing worked. 

Engineer came out yesterday, and said he couldn't actually find an active cable coming into the house from the cabinet. So may need a new cable to be laid.

As of this morning my previous broadband service got disconnected. 

Now I've  got no working broadband. 

Tried calling various departments today....but  noone is able to help....in many cases I've had to hang up after waiting over an hour either on hold or in a queue.

So can someone advise how this can be resolved?

0 Kudos
Reply
arvind74
  • 2
  • 0
  • 0
Joining in
113 Views
Message 2 of 3
Flag for a moderator

Re: No broadband...help needed

So no help from anyone....spent almost 6 hours on queues to get through to faults. No real answer.

As service isn't working and no indication when it will get resolved, and I don't have any working connection at home anymore. Cancellations is my next stop. 

Time to say bye bye virgin....a short but very unenjoyable experience for a new customer. 

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.95K
Alessandro Volta
111 Views
Message 3 of 3
Flag for a moderator

Re: No broadband...help needed

Speak to Retentions on 150 or 0345 454 1111 - options 1- 1 - 4 - 4 "Thinking of leaving" - they are open 08:00 until 21:00 BUT calling early between 08.00-10.00  midweek is best, when you will usually get a UK call centre with staff more informed and helpful. They seem to have the power of God over other departments.


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply