Menu
Reply
MissLBW
  • 3
  • 0
  • 0
Joining in
372 Views
Message 1 of 4
Flag for a moderator

New TCL TV - issues with connection

Hi everyone!

Apologies if I’m a dimwit but I’ve just got a new TCL tv and am having difficulties watching regular tv(as in I don’t know if I’ve plugged something in wrong!) plus it’s an Ultra HD tv but the picture isn’t very clear….. do I need to do something ?

 

 

 

[MOD EDIT: Subject title changed for clarity]

Tags (1)
0 Kudos
Reply
Roger_Gooner
  • 7.88K
  • 518
  • 1.48K
Alessandro Volta
345 Views
Message 2 of 4
Flag for a moderator

Re: New TCL TV - issues with connection

Do you have a TiVo? If so your post in the TiVo forum would be better. I'm tempted to say that a video output setting of 576i and 1080i would be best but there are others who know better as it's been years since I had a TiVo. Also, the TiVo does not support UHD, so you'd need an upgrade to the 360* to get the best use of your new TV.

*requires VM's broadband as well

--
Hub 3.0, TP-Link Archer C8, TP-Link TL-SG108S 8-port gigabit switch, V6
My Broadband Ping - Roger's VM Broadband Connection
0 Kudos
Reply
jpeg1
  • 6.5K
  • 336
  • 1.18K
Hero
336 Views
Message 3 of 4
Flag for a moderator

Re: New TCL TV - issues with connection

What do you mean by 'regular' TV ?

Do you have a Virgin TV box? If so, which model?

Which connection cables have you used?

Do you mean off-air TV that requires an aerial?

 

0 Kudos
Reply
Hayley_S
  • 3.9K
  • 129
  • 253
Forum Team (Retired)
Forum Team (Retired)
273 Views
Message 4 of 4
Flag for a moderator

Re: New TCL TV - issues with connection

Hello @MissLBW,

 

Welcome back to the community page, thank you for posting on here.

 

I am sorry for any issues with your connection to your TV.

 

Please can you answer the questions asked above? Then we can help you further 🙂

 

Many thanks,

 

Hayley
Forum Team



New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply