Menu
Reply
adamboles
  • 2
  • 0
  • 0
Joining in
306 Views
Message 1 of 7
Flag for a moderator

Installed M350 WiFi but speeds are extremely slow

I installed a M350 wifi today but i am struggling to get the speeds advertised. At first the speed was around 200mb download however it has been down as low as 15mb. What is wrong? 

Tags (1)
0 Kudos
Reply
Anonymous
Not applicable
303 Views
Message 2 of 7
Flag for a moderator

Re: Installed M350 WiFi but speeds are extremely slow

By default you have one SSID (Network Name) which contains both the 2.4Ghz and 5Ghz bands.

The HUB attempts to 'smartly' assign a device to a band based on a number of criteria, however it doesn't always work as expected.

In my, and others, experience, it's better to split the SSID into two, one for the 2.4Ghz band, and one for the 5Ghz, so you can choose between speed or distance, depending on where your wireless device is in your home.

Log into your HUB on http://192.168.0.1, using the password on the base (NOT the SSID key!), and append your existing network name with '_2G' and '_5G' as I have done below:

Once you 'Apply Changes' at the bottom you must reconnect all wireless devices since the SSID has changed.

Connect your devices to the '_5G' network if you can.

Keep in mind you may never 'see' the full 350Mbps speed on an individual wireless device since it's based on the capablity of the slowest hardware between your HUB and Phone, laptop, etc. Only wired devices (Plugged directly into the HUB over an ethernet cable) are guaranteed the full package speed.

0 Kudos
Reply
adamboles
  • 2
  • 0
  • 0
Joining in
243 Views
Message 3 of 7
Flag for a moderator

Re: Installed M350 WiFi but speeds are extremely slow

Thank you for the reply. This has helped on some devices however, i am still struggling to get over 190Mb download speeds. Im aware i might not get the full 360Mb download but i would like it to be closer to 360Mb otherwise i wouldve been better getting the cheaper M200 package.

0 Kudos
Reply
Anonymous
Not applicable
223 Views
Message 4 of 7
Flag for a moderator

Re: Installed M350 WiFi but speeds are extremely slow

The faster packages are designed to be used across several devices concurrently.

This is the main benefit, rather than full speed on one specific device.

Could you give an example model number of one of your devices and we can at least check what speed potentially it should be connected at?

0 Kudos
Reply
jpeg1
  • 4.53K
  • 254
  • 729
Superstar
216 Views
Message 5 of 7
Flag for a moderator

Re: Installed M350 WiFi but speeds are extremely slow

Just to be clear, the package you have is not M350 WiFi.   It's 350Mb broadband to the Hub, and you should be getting all of that when connected to be Hub by ethernet. The Hub generates WiFi, and the speeds you get from that are variable depending upon many factors.

0 Kudos
Reply
John_GS
  • 8.74K
  • 477
  • 772
Forum Team
Forum Team
174 Views
Message 6 of 7
Flag for a moderator

Re: Installed M350 WiFi but speeds are extremely slow

Hi adamboles

 

Thanks for posting and welcome to the community. My apologies for the lower speeds.

 

I've checked our system today and can see all downstream power levels are out of spec. This needs an engineer visit so I'll PM you now to arrange.

 

Kind regards,

John_GS
Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - "How to pay my Virgin Media bill"

0 Kudos
Reply
John_GS
  • 8.74K
  • 477
  • 772
Forum Team
Forum Team
163 Views
Message 7 of 7
Flag for a moderator

Re: Installed M350 WiFi but speeds are extremely slow

Thanks for joining me on PM, adamboles.

 

Just to update the thread, the technician visit was booked in

 

Kind regards,

John_GS
Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - "How to pay my Virgin Media bill"

0 Kudos
Reply