Menu
Reply
Highlighted
  • 2
  • 0
  • 0
Joining in
119 Views
Message 1 of 3
Flag for a moderator

Installation Engineer didn't turn up AND I can't register an account

So the VM Engineer was supposed to turn up today to connect the flat to the net work and deliver the hub etc. Didn't show up. No call, I haven't missed any calls, no virgin vans in sight, no communication whatsoever despite waiting for this for about 3 weeks!! We're 5 people in a house, all just starting our university studies, and I personally run my own business as well and need this internet urgently!

 

On top of this, when trying to register in account (which you need to be able to speak to an actual person on the helpline or check your engineer bookings), it says the "The details you have entered are incorrect, please check and try again." When they're absolutely not incorrect. Checked by 5 people and entered multiple times on multiple different devices. What the hell is going on?! This is absolutely appalling service.

0 Kudos
Reply
Highlighted
  • 451
  • 59
  • 74
Forum Team
Forum Team
116 Views
Message 2 of 3
Flag for a moderator

Re: Installation Engineer didn't turn up AND I can't register an account

Hi there,

Let me take a look for you.

I will send a private message so I can take some details

Thanks

Christy


Here to help! I'm a technician helping out whilst working from home. Find out more


0 Kudos
Reply
Highlighted
  • 4.53K
  • 266
  • 524
Forum Team
Forum Team
44 Views
Message 3 of 3
Flag for a moderator

Re: Installation Engineer didn't turn up AND I can't register an account

Hello ciaranh98

Thanks for you post 

Sorry to hear that the install didn't go ahead as planned 

Have you been able to find out if services can be installed or has this been classed as a non serviceable property 

Gareth_L

0 Kudos
Reply