Showing results for 
Search instead for 
Did you mean: 


Tuning in

I have just replaced my hub3 with a hub5. My phone is connected but only with my old network name and password it doesn't see my new network name? Virgin connect app also see's my hub5.



When you installed the replacement VM Hub 5, what did you do ?

1) Leave the Hub 5 to have the factory default Wi-Fi name + Password ?
2) Change the Wi-Fi name + password to be the same as the previous Hub 3 ?

Is there a little more to this E.g. VM Pods, your Wi-Fi Repeaters, Powerline / Wi-Fi extenders ?

Forum Team
Forum Team

Hi @Dcasspow, thank you for your post.

If you could please answer the questions asked by @Client62, that'd be much appreciated.

Also, have you tried doing a factory reset on the Hub 5 to see whether that makes any difference at all? Advice on how to do so can be found here.

Please pop back to us at your earliest convenience.


Don't think I changed anything when first installed. Tried a factory reset and the new network name is visible until fully restarted and then reverts to my old network name. Not using any vmpods or anything else you've asked.

Thank you for the response @Dcasspow 

Did you set up the router as seen here You can also change your Network name manually as seen there too.


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

I have done a manual name and password change, thanks for your help. Still unsure what actually happened though.