Showing results for 
Search instead for 
Did you mean: 

Hub 4 and connect app broadband connectivity issue

Joining in

Hub2 was replaced with hub4 recently to resolve  connectivity issues. Wifi is working fine now but I'm unable to see or connect broadband with conect app.  It just says lost connection.    I've tried troubleshoot, reset but nothing worked.  How to resolve this please 


Forum Team
Forum Team

Hi trnaeem, thanks for the message and welcome to the forums. 

I am sorry to hear that you are having issues with the connect app. 

Can you confirm of this happens on multiple devices and if the app is running the latest software?

Kind regards, Chris. 


Hi Chris, thanks for your reply.    Yes it's happening on multiple devices including Android and Apple.  App is reinstalled recently and is on latest software.    Not sure how to resolve the issue.    Regards 

Thank you for your response @trnaeem.

Just to confirm, does your network not show up at all in the app? What happens after rebooting the hub as seen here? When last were you able to successfully use the app? 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hi, it doesn't show up on app at all.     Problem occured since my hub2 is replaced with hub4.   Hub2 used to connect with app.  

Please help.  🤥

Forum Team (Retired)
Forum Team (Retired)

Thanks for your reply back, trnaeem.
Sorry to see you're still experiencing this issue, we'd love to assist if you have not yet resolved it since your last post here.
Please, read below:

We're sorry to hear you're having an issue with the Connect App recognising your Hub.


The first thing to be aware of is you need to be connected to your Home Wi-Fi in order for the app to connect to the Hub. It won't allow the connection if you're on a different Wi-Fi network, Guest network on your own Wi-Fi, VPN, or mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that:


For your Apple device, if you're on iOS 15 then you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data.

If you're on iOS 16 then just delete the app from your device, restart the handset, and then re-download the Connect App. 


For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 


If this also fails then we currently have a known error with some of the data in our systems that's causing the app to not recognise the Hub in a minority of instances. We're already investigating this as a high priority.


Pop back and keep us posted. 



Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs