Showing results for 
Search instead for 
Did you mean: 

Hub 3, green flashing base light forever, no internet.

Joining in

Green flashing base light for hours, no internet.

Telewest wall socket: no visible power to be switched on. 

Have tried resetting: holding reset button for 60 seconds; no dice.

Have tried rebooting: switching off power for 10 seconds and switching on again; no dice.

Text from Virgin confirms my "kit has been activated".

Is the telewest wall socket the prime suspect?

As a new customer, I saw somewhere that it takes "two days" following "delivery or collection of the kit", but this is contradicted by the text saying my kit has been activated, and I collected the kit this morning.

Please help


Very Insightful Person
Very Insightful Person

Try the Equipment activation on 0800 953 9500 again. There is a possibility that your cable has been disconnected at the street box.

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

Very Insightful Person
Very Insightful Person

A constantly flashing green base light is no signal lock. If it goes solid for a while then back to flashing there are other issues.

VM 350BB 2xV6 & Landline. Freeview/Freesat HD, ASDA/Tesco PAYG Mobile. Cable customer since 1993

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Forum Team
Forum Team

Hi Alex_C,

Thank you for your post and welcome to the community. 

I'm very sorry to hear about the issue with your broadband service. 

I have taken a look on our system and it looks as though you have spoken with the team. 

Please do let us know if you require any further assistance. 


Joining in

We have the same issue - except we've just moved to a property that seems to have a Virgin Media 'splitter' installed. (There are also, seemingly, three different places around the house where we could attempt to connect.)

We presume the previous tenants had phone / TV / broadband set up, whereas we're only after broadband. 

We're stuck on the flashing green lights, too. So frustrating. I'm WFH using my mobile data via Hotspot, not ideal.

Forum Team (Retired)
Forum Team (Retired)

Hi Mandatron, 

Thank you for your post and welcome to our forums 🙂 

I have checked our systems and your hub is unreachable, if you can ensure this is switched on, we can run further checks.


Hi Zoie,

I will switch it back on for you to run checks.

Disappointingly, we'd had a text confirmation to say a technician would be coming this afternoon but they were a no show.

Thank you for that Mandatron. I have checked this again and it is showing as unreachable. 

To be able to look into this further, I will private message you to confirm some details so we can look into this further. 


Same issue.  Box arrived today and followed install instructions around 4 hours ago.  My devices can find the wifi but the wifi doesn’t seem to be connected to the internet,  the Virgin wall socket was installed by the previous occupant around a year ago.

Really disappointing first experience as a Virgin customer this: I called the number posted above, spoke to someone who said they’d done a manual activation of my equipment, but that didn’t resolve it so she transferred me, to the wrong team.  They then transferred me to another team who didn’t answer and it cut off, I assume because they’ve gone home for the day.  It’s a bank holiday weekend and I’m supposed to be working from home on Tuesday - not a great start!