Menu
Reply
Asta1
  • 2
  • 0
  • 0
Joining in
981 Views
Message 1 of 7
Flag for a moderator

Hub 3.0 power cable doesn’t fit

I am new to Virgin so please bare with me!

I’ve fallen at the first hurdle. The power cable supplied with the hub doesn’t fit properly, both the cable connector and the socket have male parts, plugging it in has bent the male part on the power cable. While it does work, it really doesn’t fit well and feels like a fire hazard. 

I tried calling but after 25 minutes I’ve given up.

can anyone advise, does this sound right?!

0 Kudos
Reply
jbrennand
  • 20.75K
  • 2.21K
  • 3.67K
Very Insightful Person
Very Insightful Person
979 Views
Message 2 of 7
Flag for a moderator

Re: Hub 3.0 power cable doesn’t fit

Post up photos of the 2 parts

--------------------
John
--------------------

I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router +2 Airport Express's. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
Tudor
  • 7.95K
  • 639
  • 1.38K
Alessandro Volta
948 Views
Message 3 of 7
Flag for a moderator

Re: Hub 3.0 power cable doesn’t fit

Never ever seen a male plug on a power supply, only on a device or extension cable. I do know some years ago VM did ship incorrect power supplies with a hub, but they were just the wrong size of plug. 


Tudor
There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2
0 Kudos
Reply
Asta1
  • 2
  • 0
  • 0
Joining in
888 Views
Message 4 of 7
Flag for a moderator

Re: Hub 3.0 power cable doesn’t fit

@jbrennand  Hard to get a decent photo of the power plug itself, you can see the tip of the silver male part inside.

IMG_20191117_184314424.jpg

 

IMG_20191117_184404383.jpg

 

IMG_20191117_184329125.jpg

 

 

0 Kudos
Reply
Roger_Gooner
  • 6.41K
  • 468
  • 1.11K
Hero
863 Views
Message 5 of 7
Flag for a moderator

Re: Hub 3.0 power cable doesn’t fit

My adapter is model PE-1300-9AR5., P/N AEPP05647.

--
Hub 3.0, TP-Link Archer C8, TP-Link TL-SG1008D 8-port gigabit switch, V6
My Broadband Ping - Roger's VM Broadband Connection
0 Kudos
Reply
MarkGriff
  • 1
  • 0
  • 0
Joining in
631 Views
Message 6 of 7
Flag for a moderator

Re: Hub 3.0 power cable doesn’t fit

Did this ever get solved? I’ve finally got around to installing my new hub but have the same problem. The ‘upgrading to hub 3.0’ online video just plugs in but my cable is male (as is the socket on the hub)

can anyone shed any light?

0 Kudos
Reply
Cheule
  • 136
  • 6
  • 13
Up to speed
213 Views
Message 7 of 7
Flag for a moderator

Re: Hub 3.0 power cable doesn’t fit

Hi, sorry to resurrect an old one but I've just had an upgrade from a Hub 3 to Hub 4 and I've got the same problem, I failed at the first hurdle!

Both of my connectors are about the same size and no amount of pushing is going to make them fit!

 

Vivid 350 - Superhub 3 modem mode --> RT-AC3200
0 Kudos
Reply