Menu
Reply
Alones
  • 1
  • 0
  • 0
Joining in
133 Views
Message 1 of 3
Flag for a moderator

Getting installation

Been waiting since August ! Still no broadband. No one gives a reasonable answer , no compensation and no real confirmation of installation. 
they keep blaming construction works, but will not specify ! And engineers turned up outside over a month ago saying no issue! 
don’t know where to go now 🤮

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.94K
Alessandro Volta
96 Views
Message 2 of 3
Flag for a moderator

Re: Getting installation

Look at an Open Reach line and one of the providers.

It takes them about 14 days to get an install, if VM install before then cancel the Open Reach line and vice versa.


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
Alex_RM
  • 4.49K
  • 258
  • 342
Forum Team
Forum Team
88 Views
Message 3 of 3
Flag for a moderator

Re: Getting installation

Hi Alones,

 

Thanks for posting and welcome to our community 🙂

 

I'm sorry to hear there have been some delays with your installation, and for the lack of updates. 

 

Looks like out of hours construction work is needed, so construction will need to liaise with local councils etc. 

 

I can pop you over a private message to advise of the installation date we have.

 

Alex_Rm

 

 

0 Kudos
Reply