Showing results for 
Search instead for 
Did you mean: 

Faulty HUB5 power cable - loose connection

Tuning in

Hi,can anyone advise how I can get a new power cable for my HUB5 please? It had a loose connection and just cuts yet until you wiggle it again (not ideal when thermostat runs off WiFi!) . Can’t seem to manage to talk to anyone and the chat bot keeps telling me they’re no longer taking messages! I don’t want to cause unintentional damage by purchasing an unapproved power supply and potentially causing damage to the HUB. Thanks 


Forum Team
Forum Team

Hi Katherinep15, 

Thanks for using the forums to get this issue with your power supply looked into, I am sorry if this has been causing some frustration. I would be more than happy to look into this for you. 

We can get an engineer booked to take a look at your equipment and drop a new power supply off your you 🙂

I'll send you a PM now so we can get this started.

Speak soon!




Forum Team
Forum Team


I've booked the engineer visit for you, if you need to check or change the appointment you can do so on your Online Account

Please let us know if you have any further issues after the visit, we'll be happy to help again!



Up to speed

@Katherinep15 wrote:

just cuts yet until you wiggle it again

Curiously, I have (exactly) the same issue... (

Were you also seeing references to SW updates in your modem logs prior to it dying?
If we're both seeing the same issue - others are also, I would imagine!


Hi Tom

Thank you for your reply, I actually don’t know how to check the program logs, appologies. I now have an engineer coming out to me so hopefully they can fix it/replace it.

Forum Team (Retired)
Forum Team (Retired)

Hi @Katherinep15,

Please keep us updated on how your appointment goes and if you need any further help or assistance going forward. 🙂

We're here to help if needed.

Thank you! 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hi Paulina

The engineer was very helpful - he identified a fault with the HUB5 itself that was causing the power to cut out, so not the power supply after all. I now have a new HUB.

I have managed to reconnect everything however my Virgin Media Connect app is refusing to find the new HUB, and therefore I cannot manage my devices etc. Can I have some help with that please? 

Thank you

Hi Katherinep15, thanks for the message. 

I am glad that the engineer was able to get things resolved for you. 

Can you delete the connect app and reboot the hub to see if anything changes? ^Chris,

Hi Chris

Thank you for the suggestion, unfortunately though it has not worked, the app is still not recognising the hub. Do you have any other ideas? 


Hey @Katherinep15, thanks for the reply on the forums.

I'm sorry to hear that the app has not recognised the hub, please try the following:

For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data.
For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache.

If you are using an Android device can you please ensure you have the following settings enabled:
Location Permissions (Settings > Apps > Virgin Media Connect > Permissions)
Nearby devices (Settings > Google devices & Sharing > Scan for nearby devices).

Let us know how it goes.

Kind regards,

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs