Menu
Reply
Ericalisw
  • 1
  • 0
  • 0
Joining in
152 Views
Message 1 of 2
Flag for a moderator

Did not receive Hub for self installation

I’ve been waiting to receive my Hub as part of the QuickStart kit but I’m yet to receive it despite two phone calls to Virgin. The orders I’ve placed don’t show up on my account online either!

By way of background, I moved to a new flat and since I’m switching from a TV and Broadband package to a Broadband only rolling contract, I got asked repeatedly to return ALL my equipment (including the Hub). I did that despite questioning this several times - surely I should be able to take the Hub with me to the new place?? Anyway to avoid the penalty charge I returned it. 

When I arrived at my new flat, I found that Virgin had only sent me a connecting cable! Without the Hub! Which means that I am still unable to use any Internet, and especially given the work from home situation this is incredibly stressful.

I called Virgin twice about this, once on Saturday and one today (Monday), but I don’t see any emails confirming my order, no texts, and nothing on the “my orders” section on the Virgin portal either.

I am desperate for Internet so I can use Wifi to work instead of my phone data hotspot.

Any help would be appreciated. I don’t know what to do.

Tags (3)
0 Kudos
Reply
VM-Jon
  • 938
  • 149
  • 184
Forum Team
Forum Team
149 Views
Message 2 of 2
Flag for a moderator

Re: Did not receive Hub for self installation

Let me check this for you, I will message you privately for your details 


Here to help! I'm an install manager helping out whilst working from home. Find out more


0 Kudos
Reply