Showing results for 
Search instead for 
Did you mean: 

Connect app

On our wavelength

Why can’t the Connect app see my hub 3


Message in the app is "Hub not found. We can't find your hub. Please follow these steps.". 


Screenshot_20230116_142530_Virgin Media Connect.jpg

Hi leon_funnell  

Thanks for posting.

Have you got any VPN's active on that device? If not, as you've already tried the clear cache/data then I'm afraid it's part of a known issue which we're working on fixing asap.

Best wishes,

Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

No VPN. Any ETA for a fix?  I have pods to install and the app is the only way

I am having the same issue and need this resolved asap. I have also tried all the advice which has been posted across the forum.

Tuning in

I'm having the same issues just had a new router fitted after lightning fried our local area now connect app can't find router. I've tried everything from reinstalling router, app and clearing cache but still no joy.

I've only been with virgin for a month and it's been a month of issues the lightning strike aside the service has been really poor.

Started with Virgin Media today, receiving my Hub 3. Connect App on iPad says ‘we can’t find your hub’ (even though I’m connected to internet through it), whilst iPhone has the 2 swirling dots.

Have tried all the above suggestions, with no success.

Not a good 1st day.


Forum Team (Retired)
Forum Team (Retired)

HI pepsimax73, 

Thank you for posting. 

I am very sorry to hear your app is having trouble finding the equipment. 

The first thing to be aware of is you need to be connected to your Home WiFi in order for the app to connect to the Hub. It won't allow the connection if you're on a Guest network, VPN or Mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that: 
For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. 
For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache.  
Pop back and keep us posted. 



Amazing help Kath, I'l contact you by PM so I can send the screenshot

Up to speed

The connect app has never found my hub 3, the whole time this post has been running.  I am guessing this is something that has never been fixed?

Hi @HornetUK 👋.

Thanks for reaching out to us. Apologies in the delay in responding. Can I ask are you still having issues with the Connect App linking to your Hub 3 and also what actions or steps have you tried so far in resolving this? 

Please let us know.