Showing results for 
Search instead for 
Did you mean: 

Connect app issue

Tuning in

We had a major outage in our city for the last few days.. Finally came back on last night.

Now the Connect app isn't working.

I have tried unistalling and reinstalling the app

Resetting the hub 3

Rebooting the hub 3

Leaving the ssid and password as default 

Changing the ssid and password to the ones it was before the outage.

Nothing is working, the Connect app just keeps saying it can't find the hub.

Anything else I can do.? 


Forum Team
Forum Team

Hi closetchimp

Thanks for posting and welcome back to the community.

Sorry to hear of the issues with the Connect App.

What device are you using please? Have you also got a VPN on that device? 


Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

Hi john.

I'm using a galaxy s20, it hasnt got a VPN on it.

I have tried clearing the cache and data on the app before trying to connect the app to the hub but this didn't help either. It just keeps saying 'can't find hub'. 

Forum Team (Retired)
Forum Team (Retired)

Hi closetchimp, 

We're sorry to hear you're having an issue with the Connect App recognising your hub. 
The first thing to be aware of is you need to be connected to your Home WiFi in order for the app to connect to the Hub. It won't allow the connection if you're on a Guest network, VPN or Mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that:  
For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 
If this also fails then we currently have a known error with some of the data in our systems, that is causing the app to not recognise the Hub in a minority of instances. We are already investigating this as a high priority. 
Pop back and keep us posted. 



Hi Natalie,

Thanks for coming back to me. I have tried all the suggestions and it's still not working, it keeps failing to find the hub. 

Hi Closetchimp, thank you for coming back to us. Sorry to hear the app is still not working for you!

Can you please check:

1) The connect app has location permissions enabled? (You can do this by going to Settings > Apps > Virgin Media Connect > Permissions) 

2) That Nearby Devices is also enabled. (Settings > Google devices and sharing > Devices > Turn scan for nearby devices on)

Let us know if you have both of these enabled and the app is still unable to locate the hub so we can offer further support! If this does not fix the issue - please let us know which operating system your device is running as we will need to raise an IT ticket. 

All the best.