Showing results for 
Search instead for 
Did you mean: 

Connect app does not work with Hub 4

Tuning in

I’m a new customer, I’ve had 4 VM employees out to my house now but the app does not connect to my phone so I can’t see black spots and last night for almost 2 hours I got a message on my iPhone and iPad saying I had the wrong password for my VM account (I hadn’t as it had been working all day!). 
how can I get the app to connect please, I’ve got an iPhone I’ve reinstalled the hub numerous times, 2 technicians have been out and fiddled with the speed at the green box on my estate but it’s still not working so I don’t actually know if I’m getting the service/fibre broadband speeds that I’m paying for! As a new customer it’s really frustrating 


Alessandro Volta
VM stopped caring about the app check speed here

Forum Team
Forum Team

Hi SarahG44, thanks for joining our help forum and welcome to the community.

We're sorry to hear of the issues with our Connect App on your apple devices, also about the service issues faced currently.
In regard to the service being slow, we are not experiencing area faults at the minute, how are things going since you last posted on Monday if we may ask?

Could you also let us know if you've tried to uninstall and re-install the app as we have recently launched a newer version that connects to your hub 4 without needing a pair-up?
Also, is this happening on an android phone if possible to check this?

Let us know of the above, happy to best assist you based on your feedback.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

I have rest it, disconnected it, restalled it and 2 Virgin engineers have been into my home and fine this too!

it’s pointless, the hun 4 does not work with iPhone/iPad!!!! Please don’t ask me to reinstall it again as IT DOESN’T WORK!

I’m getting really frustrated now because you keep suggesting the same thing! 


Hi @SarahG44,

Thanks for the update on this, I'm sorry to hear things still aren't working. I've taken a look on our end, and everything seems to be all green, there are no issues being detected. 

The Connect App is compatible with the Hub 3, 4 and 5. Can you please try to use an alternative device, to see if this allows you to connect to the Connect App? In addition, please ensure you do not have a Mobile Data service active whilst connecting to the Hub 4, and you are connected to the Wi-Fi directly. If your Hub is also in Modem Mode, the Connect App will not work.

You have also mentioned the "Hub 4 does not work with iPhone/iPad" - is this a case where the devices aren't connecting to the Wi-Fi? Are there any specific error messages when connecting to these devices?


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Tuning in


This is the error message I get on all platforms I’ve tried iPhone and iPad now too as advised.

Can I ask about Modem mode? How do I know if my hub 4 is on it? Should it be on modem mode all the time?  Can I also ask about internet speeds please. What SHOULD they be as I did a speed test and it’s nowhere near the speed I pay for? 


I have also included a screenshot of that 

This is what my speed test says today!! 


And this is with the booster you sent us? My son is also complaining that his WiFi keeps dropping out! It’s incredibly frustrating and as a new customer I’m starting to regret moving my broadband service!!! 

Very Insightful Person
Very Insightful Person

Hi @SarahG44 

The Connect app for iphone does now work with the hub 4  - The latest version, 12.28.18 was only released on Thursday. If you are on IOS you can force the latest version by going to the app store.

(The android version is being updated in stages, however on android there is no way to force it but any android owners should get it by the 12th Sept)

I notice you are measuring your speeds on an iphone.  VM don't guarantee wifi speeds.

If possible measure the speeds on either a PC or laptop with an ethernet connection on the following site which shows speeds to the hub and speeds to your device  


You can check if your hub is in modem mode by opening a browser and typing in   

Then click on Modem Mode - this should have a tick in the Enable Router Mode radio button box by default - if the tick is in the Enable Modem Mode then that confirms you are in modem mode.

The shouldn't actually work if you are in modem mode - when in modem mode you need to type in to check the stats or switch mode.

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali