Showing results for 
Search instead for 
Did you mean: 

Cannot find hub on VM Connect

Joining in


I have just had a Hub 5 installed and I cannot find it on the Wi-Fi connect app.

I get two results. “We can’t find your hub” prompting me to try again or “Installing your hub”, which it will try for 30 minutes or so before saying it was unable to.

So far I have tried

  • Resetting the hub to factory settings via the reset button
  • Disabling all security on the hub
  • Reinstalling the app

Nothing has solved it. I have a dead spot in my home which I wish to get a booster for. But I need to scan in the app to confirm the dead spot.

Running iOS 16.4.1


Very Insightful Person
Very Insightful Person

The app is a bit temperamental at times  Just make sure you are connected to the VM network and not running any iOS Private Relay or VPN's.  It can also take several attempts over a few days to get connected, as the "back end" of the app needs to catch up with your new account details.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Forum Team (Retired)
Forum Team (Retired)

Hi Tsargeant3012, thank you for reaching out on our help forums and for your first post here.
A warm welcome to the VM community, we're glad to have you on board with us! 🙂

Sorry to hear about the Connect App not finding your hub, if your above post was made on the day the hub 5 got installed we'd need to allow about 24-48 hours so the App can successfully locate the hub and link up.

Do pop back here with an update and let us know if things are working ok for you now, as it's been 2-3 days after your service installation.

We're here and eager to assist in case you need more help with this. 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs