forumarchive,nothingtosee,
Menu
Reply
Jetlagged
  • 13
  • 0
  • 0
Tuning in
57 Views
Message 1 of 1
Flag for a moderator

Cannot access Virgin Media - "Your connection is not private" error.

Since changing over to Virgin Media, when I use my desktop PC I get "Your connection is not private" error on SOME websites. My tablet and smartphone are fine and the PC was fine until the day that I switched to Virgin Media.

When trying to access some sites I get an error message. The full message is:

“Your connection is not private

Attackers might be trying to steal your information from www.amazon.co.uk (for example, passwords, messages or credit cards). Learn more

NET::ERR_CERT_COMMON_NAME_INVALID

www.amazon.co.uk normally uses encryption to protect your information. When Google Chrome tried to connect to www.amazon.co.uk this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be www.amazon.co.uk, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Google Chrome stopped the connection before any data was exchanged.

You cannot visit www.amazon.co.uk right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.”

 

I have posted this before but am still having problems so I’m looking for new suggestions to fix this issue.

I’m running Windows 10 Pro and usually use Chrome and both are regularly updated. I’ve tried Edge but that has the same problems. So far I've tried using incognito mode, updating the PC clock, clearing cache/cookies, etc. The only way I can find around the problem is to connect via a VPN.

The sites affected include, but are not limited to, Amazon UK, Amazon DE, UK lottery and my bank. The Amazon sites in Italy, Spain and France work OK but not the UK or Germany sites. And get this. I even get blocked when trying to access Virgin Media!

This has to be something connected to my change to Virgin Media as that is exactly when the problem started,

I'm at my wits end now trying to resolve this and would appreciate any and all help please.

0 Kudos
Reply