Showing results for 
Search instead for 
Did you mean: 

Can't register hub on app

Joining in

Hello. I have received my hub 3 today and have successfully set it up. The WiFi is working well however I can't link the virgin connect app to my hub. Whenever I try to do so, it asks me to install my hub. When I do, it says the installation failed (despite the hub working and being online). If I click to say that I have already installed the hub, it says it cannot find it. I have tried uninstalling and reinstalling the app, rebooting the hub, factory resetting the hub but nothing seems to work.


Trouble shooter

Leave the Hub online.  The issue is the VM Connect app is flaky.

All you can do is check that your device does not have a VPN running, the link below should show ISP : Virgin Media and try the Connect app again later tomorrow perhaps.

To manage the Hub 3 directly  : ( Hub 3 password is on a label on bottom side )

To speed test the Hub 3 and your device :      once started click: Run full test to see all the figures.

Forum Team
Forum Team

Hello Kakili, 

Welcome to the Community and thank you for posting. 

I am very sorry for the issues with connecting your new equipment on the connect app , we will do all we can to help. 

The first thing to be aware of is you need to be connected to your Home WiFi in order for the app to connect to the Hub. It won't allow the connection if you're on a Guest network, VPN or Mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that: 
For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. 
For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 

Please let us know if this helps.