Menu
Reply
Nudge71
  • 5
  • 0
  • 0
Joining in
332 Views
Message 1 of 7
Flag for a moderator

Cable issue…

Just received my new pack (broadband only). Have connected the hub3 to the power, but the connector in the back and on my wall socket is threaded but the supplied splitter cable provided is push-in and no way will push in without breaking. how is this possible that it’s not compatible with the hub? 

0 Kudos
Reply
JOE-C
  • 106
  • 18
  • 21
Forum Team (Retired)
Forum Team (Retired)
322 Views
Message 2 of 7
Flag for a moderator

Re: Cable issue…

Hi the cables provided are designed to push onto the threaded outlets. It will go on, you will need to push firmly.

If you would like to attach photos so i can make sure you have what you need please feel free.

Thanks Joe 


Here to help! I'm a technician helping out whilst working from home. Find out more


0 Kudos
Reply
Nudge71
  • 5
  • 0
  • 0
Joining in
300 Views
Message 3 of 7
Flag for a moderator

Re: Cable issue…

Here you go Joe…both ends. 

0 Kudos
Reply
Nudge71
  • 5
  • 0
  • 0
Joining in
291 Views
Message 4 of 7
Flag for a moderator

Re: Cable issue…

6CD90EF7-D17D-4835-97CB-585A3A62C12E.jpeg

0 Kudos
Reply
Nudge71
  • 5
  • 0
  • 0
Joining in
290 Views
Message 5 of 7
Flag for a moderator

Re: Cable issue…

BFECFCA4-94B1-461E-BD9D-B220E5B47843.jpeg

0 Kudos
Reply
JOE-C
  • 106
  • 18
  • 21
Forum Team (Retired)
Forum Team (Retired)
273 Views
Message 6 of 7
Flag for a moderator
Helpful Answer

Re: Cable issue…

Yes those should push on just fine. Push them on quite firmly as far as they go, they are designed to push onto the threaded outlets at both ends. 

Thanks Joe 


Here to help! I'm a technician helping out whilst working from home. Find out more


0 Kudos
Reply
Nudge71
  • 5
  • 0
  • 0
Joining in
261 Views
Message 7 of 7
Flag for a moderator

Re: Cable issue…

That’s worked. Thanks Joe. I was scared of breaking the cables…👍🙈

0 Kudos
Reply