Showing results for 
Search instead for 
Did you mean: 

App won't connect to hub 3

Joining in


Just got virgin hub. The virgin connect app won't connect to my hub 3. I followed instructions in app , I have tried rebooting both phone and hub. Reset hub restarted hub and tried removing app and reinstalled app. Also even though the Internet is working fine the power light on hub I a light orange colour.

Thank you in advance for any information given to sort the issue 

Cheers Chris 


Forum Team
Forum Team

Hi there @Robbo1971


Thank you so much for your post and welcome to the forums, it's great to have you on the team! 


I'm so sorry to hear that you are facing this issue with your App and Hub! 


Just to check is the Hub hot at all to the touch? Also is the light orange or red. 


Have you tried clearing the data within the app?


Thank you.

Hi Ash 

Just sorted the app out this minute. 

Went into hub settings had a nosey around come back out and now the app work, no idea what I did but it worked 😁.

The hub is not hot and is working fine,  just light is a very light orange.

I have seen a few comments saying they had same issue and people saying it's the led.

If that's all it is I'm fine with that.

Cheers Chris 

Thanks for coming back to us an confirming @Robbo1971.

Do please come back to us if you face any further issues, with the app and the connection.

If the hub is hot to touch - which is usually recognised via the light turning a solid red, we will need to arrange for this to be replaced

Kindest regards,