Showing results for 
Search instead for 
Did you mean: 

firmware update has broken hub 4

Fibre optic

your firmware update this weekend has broken the hub 4. LAG connections no longer work preventing full network speed.


Can you please.

1) Revert the change. Give us back the old firmware.


2) Provide hub5 in order to obtain full network speed.

Without either of the above VM have lost their sole advantage of a slightly higher download speed compared to BT et al, who also have the advantage of twice the upload. so  a very retrograde step.

Hub4/Gig1-> pfSense->Microtik CRS312/CSS326/CRS305->Meshed Asus RT-AX89X
VM Network - Timwilky

Very Insightful Person
Very Insightful Person

I doubt if VM will roll back the firmware.  Be best to push for the Hub 5 really.  As you know it has the 2.5Gb port.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Alessandro Volta
900Mb...thats all VM had to say but Noooo 1Gb they went.

Very Insightful Person
Very Insightful Person

The LAG facility on the Hub4 was never advertised as being available or supported by VM. Also VM have never advertised that the Hub4 could support 1G on a SINGLE Ethernet connection. It can support 1G shared over Ethernet and WiFi with multiple connections. While I don’t necessarily support all that VM does, you have to be very precise with definitions. 

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

And I do have to agree with Tudor above, the fact that LAG worked on the hub 4 previously was always, always an unsupported 'feature', which probably worked more by accident than design; on that basis if a subsequent update broke it, well then, unfortunately sorry about that, but fair enough really.

VM are absolutely not going to roll the firmware back, I'm afraid that ship has sailed, neither are they going to spend money on engineering time to reinstate this feature.

So the question here is 'what are you going to do about it?

My contract expires in 3 weeks. I am already looking for alternative providers, whilst not overly annoyed by the 20% loss of download whilst still being charged for it. I really want better upload So alternatives were up for consideration despite the downgrades being installed by VM

Hub4/Gig1-> pfSense->Microtik CRS312/CSS326/CRS305->Meshed Asus RT-AX89X
VM Network - Timwilky

Must have been a network issue last night as i have the same packet loss spikes as you did and i am on hub 5



Up to speed
Yup. Unsupported feature unsurprisingly goes away, service downgraded, alternatives suddenly look better for download and the rug is finally pulled.

But there's no defence of this craven false advertising. 1g is 1g; that's the speed you should expect, no ifs, no buts. You don't just get to redefine the meaning of claims, even if you're a fully paid-up member of the Virgin Media exclusive fanclub. I signed up with the reasonable expectation of not being limited to sub-gigabit and I was rather surprised to get the Hub 4 in the first place. Sadly, right now, I'm in contract and the altnets haven't quite made it here (but close), so I'll need to suffer just a little while longer.

With impeccable timing my 30 days notice is up and I have jumped ship from VM to CityFibre. 

Noticed the green light on my Hub 4 in the final days and the loss of LAGG bonding into my Mikrotik router. 

The FTTP service is next-gen leaps and bounds better than VM. The router even has a 2.5G port and an SFP cage for future expansion.

Hope you chaps get the firmware fix for the HUB 4 soon.

Did virgin put you onto CityFibre network? They are still in the process of installing it in our area as was told by CityFibre, you have to ask your current provider to switch to it.

——————————————— My Broadband Ping - Virgin 500mb Home Connection