Showing results for 
Search instead for 
Did you mean: 

Zscaler blocking internet?

Joining in


I have had constant issues with internet access seemingly being blocked by Zscaler. I know my VM internet is working because my personal phone and work phone are connected but I cannot log on, sometimes for a couple of hours, onto my work systems or the internet at all on my work laptop. It is a new issue since a move from Pulse secure to Zscaler.  

There seems to be no issue with my laptop, or from my work side - does anyone else have the same issue and know how to fix it? It is incredibly frustrating and makes WFH sometimes extremely difficult. 

Many thanks 



Forum Team
Forum Team

Hi Anna, thanks for the message and welcome to the forums. 

I am sorry to hear that you are having issues with the service and this is not the experience which we want you to have with us. 

Can you try troubleshooting on the following link here

Please let us know how it goes?


Hi Anna/ Chris 

Arec you able to advise how this was resolved ? I am having a same issue with connection and zscaler but my work laptop/zscaler have remained unchanged. 


Thank you 

Alessandro Volta
See if hub in modem mode works

Thanks for your post on our Community Forums @RR2023, and a very warm welcome to you!

Can you please confirm if you were able to access the website when the hub was place in modem mode, or did this produce the same result for you?

Kindest regards,


Hello David, 

When I changed the router into Modem mode ( Red colour on the hub), I could not re-connect back to the internet. I used a ethernet cable plugged into the router directly from my laptop. Please advise ? 

So connection keeps dropping/lagging that I unable to use teams/work application but seems to come back after a couple of hours ?

Hi @RR2023 

Welcome back to our community forums and sorry to hear you are having a similar issue with your service and hub.

I can however see that you have been able to reach our team to book an appointment. Please let us know how the appointment goes and if you need any further help. 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Joining in

I have VM on modem mode and have for years. 

We use zscaler for work (ZIA and ZDX) and recently switched off the NAT DNS setting that forced the zscaler client to use zscaler's own trusted dns server. This had the effect of stopping my pc doing dns resolution - my mac which also uses zscaler was unaffected.

I think I've found a simple fix for myself and other VM users of ZIA/ZDX - open the zscaler client, click on more, choose repair app then click on restart service. This ( i think ) cleans up the previous dns settings and allows the use of virgin's dns servers 

I'm also an admin for zscaler at my company and I also tried using a custom PAC file to allow the above IPs to go direct ( as in not tunnelled.) But I think restarting/fixing the client was the fix. I've tried this with a couple of colleagues who had the same problem and they have confirmed this as a fix.