Menu
Reply
JonEFresh
  • 11
  • 0
  • 1
On our wavelength
174 Views
Message 1 of 11
Flag for a moderator

Wifi slower on new laptop than on phone

Hi, I have a Hub3 and recently upgraded my Virgin broadband speed from M100 to M200 and bought a new laptop that only has a Wifi 5 802.11 ac connection.  I find i connect with my laptop and get a max speed of 50Mb which then decreases over seconds to 10Mb or so.  On my phone i get just over 205Mb constantly.  How can i get my laptop to connect at the same speed as my phone?

Thanks

0 Kudos
Reply
RedGooner
  • 1.88K
  • 66
  • 248
Super solver
162 Views
Message 2 of 11
Flag for a moderator

Re: Wifi slower on new laptop than on phone

For starters the WIFI on the SH3 is USELESS, remember its given away FREE by VM.

Now what band of WIFI you using 2.4GHz or 5GHz.

How far are you away from the SH is the Laptop.

--
Red (VM SH2 AC Beta tester)
Running on 1Gbps VM service with SH4 in Modem Mode, with a ASUS RT-AC5300 router. With this setup I get Fantastic WIRED and WIRELESS Signals in my home. I dont work for VM. But I work in IT, and I know my tech.
My advice is at your own risk. If you are happy with my answers please press Kudo ?
0 Kudos
Reply
JonEFresh
  • 11
  • 0
  • 1
On our wavelength
148 Views
Message 3 of 11
Flag for a moderator

Re: Wifi slower on new laptop than on phone

Hi, Thanks for the reply.

I am very close to the router, but this has been the same for years using my previous 5 year old laptop.

I have tried various frequencies on the router, most recently i switched it to 5G only and phone still gave me 210Mb where as the laptop gives me initially 105Mb then reducing to 45Mb by the end of the speed test

0 Kudos
Reply
RedGooner
  • 1.88K
  • 66
  • 248
Super solver
142 Views
Message 4 of 11
Flag for a moderator

Re: Wifi slower on new laptop than on phone

Whats the make and Model of your Wifi card in your laptop.

Have you checked to see if there are any updated drivers for it.

--
Red (VM SH2 AC Beta tester)
Running on 1Gbps VM service with SH4 in Modem Mode, with a ASUS RT-AC5300 router. With this setup I get Fantastic WIRED and WIRELESS Signals in my home. I dont work for VM. But I work in IT, and I know my tech.
My advice is at your own risk. If you are happy with my answers please press Kudo ?
JonEFresh
  • 11
  • 0
  • 1
On our wavelength
128 Views
Message 5 of 11
Flag for a moderator

Re: Wifi slower on new laptop than on phone

Hi, Thanks for the reply.

I am very close to the router, but this has been the same for years using my previous 5 year old laptop.

I have tried various frequencies on the router, most recently i switched it to 5G only and phone still gave me 210Mb where as the laptop gives me initially 105Mb then reducing to 45Mb by the end of the speed test

Just tested again and it stays at 47Mb the whole test.  I checked my systems resources and during the speed test they were about 50%, my laptop is an acer aspire 5 ryzen 5 4200, 8GB, SSD

0 Kudos
Reply
JonEFresh
  • 11
  • 0
  • 1
On our wavelength
124 Views
Message 6 of 11
Flag for a moderator

Re: Wifi slower on new laptop than on phone

my wifi card is Qualcomm Atheros QCA61x4A Wireless Network Adapter and there are no new drivers for it

0 Kudos
Reply
g0akc
  • 585
  • 59
  • 119
Rising star
122 Views
Message 7 of 11
Flag for a moderator

Re: Wifi slower on new laptop than on phone


@JonEFresh wrote:

Hi, Thanks for the reply.

I am very close to the router, but this has been the same for years using my previous 5 year old laptop.

I have tried various frequencies on the router, most recently i switched it to 5G only and phone still gave me 210Mb where as the laptop gives me initially 105Mb then reducing to 45Mb by the end of the speed test

Just tested again and it stays at 47Mb the whole test.  I checked my systems resources and during the speed test they were about 50%, my laptop is an acer aspire 5 ryzen 5 4200, 8GB, SSD


Check if the Wi-Fi drivers are up to date (already asked).

install inSSIDer app on the laptop and scan - see if there’s a neighbouring hub or better channel to use.

------------------------------------------------------------------------------------------------------------------------------
I know a bit about Wi-Fi, Telecoms, and TV as I used to do it for a living but I'm not perfect so don't beat me up... If you make things you make mistakes!
0 Kudos
Reply
JonEFresh
  • 11
  • 0
  • 1
On our wavelength
121 Views
Message 8 of 11
Flag for a moderator

Re: Wifi slower on new laptop than on phone

my wifi card is Qualcomm Atheros QCA61x4A Wireless Network Adapter and there are no new drivers for it. my laptop is and acer aspire5 ryzen 5 4200, 8gb, ssd

0 Kudos
Reply
RedGooner
  • 1.88K
  • 66
  • 248
Super solver
103 Views
Message 9 of 11
Flag for a moderator

Re: Wifi slower on new laptop than on phone

I am guessing you have WIN10.

When the Laptop is connected to WIFI, goto Task Manager. Then Performance Tab.

Select the WIFI card, and you should see a graph update every second. Hover over the graph, and click Right Mouse Button, and select "View Network Details"

It will bring up another box with loads of info, i am after the Bit that says "LINK SPEED", please post that here, and watch it over a few mins.

--
Red (VM SH2 AC Beta tester)
Running on 1Gbps VM service with SH4 in Modem Mode, with a ASUS RT-AC5300 router. With this setup I get Fantastic WIRED and WIRELESS Signals in my home. I dont work for VM. But I work in IT, and I know my tech.
My advice is at your own risk. If you are happy with my answers please press Kudo ?
JonEFresh
  • 11
  • 0
  • 1
On our wavelength
74 Views
Message 10 of 11
Flag for a moderator

Re: Wifi slower on new laptop than on phone

Hi, really strange. The figure you wanted was 867 Mbps, which i thought was a lot, so i did speed test and monitored the link speed as you said to.  The speed was constantly 867 and i noticed the wifi utilization was only 27%, so i checked back on the speed test and... it said 212.18...omg  It has been less than 50Mb for weeks and today when i finally ask for help it starts working.  Admittedly, i had earlier changed the 5Ghz on the router to only be for ac and not a&n too, so i suppose i was splitting the available bandwidth or something.

Thank's so much for your help RedGooner, just having knowledgeable people willing to go through things with you is amazing

0 Kudos
Reply