Showing results for 
Search instead for 
Did you mean: 

Wifi settings error message - Connection Timed Out

Joining in

So I’m trying to connect Meross smart plugs to the WiFi, to activate remotely.

To do this, Meross requires WiFi to be on 2.4GHz only. So I logged into the WiFi settings using my phone, as per the label on the Hub4 WiFi box login info ( etc), and deselected the 5GHz option, leaving only 2.4GHz active. I have done this successfully before this way.

However today it was loading for several minutes, and then showed the error message “Connection timed out” on a blank white screen.

I’ve since reset the WiFi box several times, turned it off/on, unplugged the Ethernet cable etc and plugged it back in, waited 20 mins, but am still getting this error message over an hour later.

I even cleared my phone browser history and tried logging in again, but still get the same error message.

Any advice???! I cannot programme my smart plugs with 5GHz WiFi setting on, I think it needs to be temporarily off to work!

Thanks in advance! 


Forum Team
Forum Team

HI Zchakhe, thanks for the message and welcome to the forums. 

Can you confirm if you are still having issues with the time outs since posting? 

Would you be able to create a BQM here and send us the results.