Showing results for 
Search instead for 
Did you mean: 

WiFi pods not working with new hub

Tuning in

Why having been told to change my hub do my  WiFi pods not work. What 24 hour clock do virgin work on? Despite 2 promises of a return call with 24 hours both promises broken


Very Insightful Person
Very Insightful Person

The backend database for the Pods can take a couple of days to catch up with new Hub installs.  Agree though that this should be done on dispatch of a new Hub. 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Forum Team
Forum Team

Hi @yorkie1971 

Welcome back to the community forums

Sorry to hear you're concerns with your WiFi pods. I have checked the systems at our side and can see that the provisioning team have noted that this has been completed for you. 

Please let us know if you are having any further issues or have any questions at all. We'll be here to help on the community forums if needed :). 

Here to help 🙂
Virgin Media Forums Agent

Good evening

I'm also in a similar position. I've recently had a new hub installed and now my WIFI pod will not connect to the new hob nor is it showing on the V Connect app.

The pod was essential for my house to boost the signal upstairs whilst working from home. I have tried all the work around on the forum and nothing has worked. Also trying to get in contact with Virgin Customer Services is an absolute nightmare. Kept on getting pushed back with text message links its so annoying. 

The service of my broadband over last 6 week has been ridiculous causing me to log complaints and now further issues. 

Is there anyone here who can support pls as myself and my partner are home workers, it's just continuously being a frustrating situation 

Kind regards