Showing results for 
Search instead for 
Did you mean: 

WiFi pods not working properly

Joining in

Got a hub 3. I had 1 WiFi pod for a while, but having a 100 year old solid brick house, I still had some dodgy spots. 


With the 1 pod, it massively improved what we had, where it worked. On the connect app I could see more than 1 item was linked to the pod. It would also show how many were connected to the router. 

I got the 2nd one, both are connected. Connect app shows great connection for both. 


But we have had so many WiFi issues ever since. Speed, when it works is generally fine, but it randomly drops off, WiFi will show with an ! Next to it, theb my phone will say no internet. Itl do this randomly and frequently and stop buffering videos. 

On the connect app, I get good speeds, however it must have dropped off when doing 1 test as it came up with an error but then worked after. 


But, now on the connect app, there is a bubble on both pods with just the number 1, and now everything else is connected via the router. 

I now also can't work out how I managed to view what was connected to the pod. I swear I just tapped it and it told me. Now I tap it and I get the pods data. 

If I click on the WiFi, it shows me what's connected to it on there. 

It's annoying me now that I have poor internet due to these, and know it can work, I just seen to have an issue now I'm using 2



Forum Team
Forum Team

Hello Milner19.

Sorry to hear about the pods not working as they should do.

Can I ask if the lights are evident on them, pulsing slowly?

It might be worth unplugging the pods rebooting the hub and plugging one pod in as close as possible to the hub. Then try relocating it to where it was originally.

If you are still having issues, please let me know.


Tha is for your reply. 


Sorry for my late reply.

I tried doing what you said and so far it seems to of improved. 

However I am confused to how it works. 

My router is in the front room, I have 1 in the upstairs bedrooms on the opposite side of the house, and 1 at the back of the kitchen. Both pods on the connect app say 'great connection' 

However, we have an echo dot in the bedroom the pod is in, that's not connected to that pod, I'm currently sat just outside the back door, directly behind the pod in the kitchen, I'm actually connected to the front bedroom one. 

It appears there are 2 of the echo dots connected to the kitchen one. I can only assume the actual one in the kitchen, and probably more bizarrely, the one in the bedroom, that has a pod in it. 

So instead of me being right next to the kitchen pod now, receiving full WiFi signal, I'm actually receiving 1 bar of WiFi, because it's connected to something further away at a different elevation 🤔

Screenshot_20231107_161909_VM Connect.jpg

Screenshot_20231107_162000_VM Connect.jpg

Can you try rebooting the devices as they should connect to the strongest signal which would be either the Hub or the nearest Pod. Let us know if this helps Milner19.