Showing results for 
Search instead for 
Did you mean: 

Virgin connect app issue

Joining in


I have just had virgin installed 2 days ago and I'm already having issues. Whenever I try and log into the connect app all it says is 'we couldn't connect you to the server'. Also when I Try and access my account on the my virgin app it says that my services haven't been installed yet?. I have been on the phone to the tech team and still no further forward I have tried the resetting of the hub reinstalling the app still nothing?. Any help would be appreciated as its getting pretty frustrating and I'm only 2 days into having service with virgin not a good look.


  • Thanks

Very Insightful Person
Very Insightful Person

The Connect app is an exercise in frustration.  Sometimes it works and other times not.  There are many reports on this Forum about the app not working correctly.

However, there isn't much you can do with the app, that you can't do with the admin console on the Hub directly.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Forum Team
Forum Team

Hi Kris5,

Thanks for your post and welcome to the community.

Apologies for the issues faced with the app, just to clarify has this been tried on multiple devices?