Showing results for 
Search instead for 
Did you mean: 

Virgin Media Connect App Not Working

Joining in

VM Connect App not working for me.

Screenshot_20231121_222725_VM Connect.jpg


Forum Team
Forum Team

Hi @Ad4m thanks for your post here although we're sorry to hear of the concerns you've raised here.

Can you confirm what it is you're trying to do via the app please? 

If this is still not working for you, could you please try to uninstall and reinstall the app to see if this works for you?

Many thanks


Hi Tom,

Thank you for your help.

I was wanting to pause a device but the Virgin Media Connect App was not displaying any devices connected to my Hub 3.

I did have connectivity but i was unable to use the VM Connect App as it wasn't working.

I checked today and it seems to be working ok, very slow though.

I deleted the app andvre installed and its still the same. Very slow to respond.

Thanks for the update and glad to hear the original issue is now resolved. Over the coming weeks an update to the Connect App is being rolled out to all users, this should help with the connectivity and responsiveness issues, we'd ask to ensure when an update is available this is completed and any feedback on this you can leave here 🙂