Showing results for 
Search instead for 
Did you mean: 

VM Connect app can't find Hub

Joining in

As stated in the title, the app won't find the Hub. I've waited more than 48 hours as suggested by the FAQs. What can I do?



Manage the Hub via its menu at

Forum Team (Retired)
Forum Team (Retired)

Hi Edrewdle,

Thanks for your post and welcome to the community.

Sorry to hear you've been experiencing problems with the Connect app, have you ever been able to connect at all?

Is this a recent install?



Installed on 18 September. I've never been able to connect

I'm so sorry to hear this @Edrewdle and thank you for popping back. 

Can I ask if you have tried uninstalling and reinstalling the app as well as clearing app data? 

I've tried that. I've also tried switching the hub off. Nothing works, the app won't connect to the hub. 


The state of the Hub is not the issue. 

The app finds the Hub via VM back office systems,  until those systems are update to reflect the current Hub the VM Connect app is unable to work.

Other things that can stop the VM Connect app from working :

1) Failing to uninstall / re-install VM Connect app following a change of Hub.

2) Using a VPN on your mobile. ( iPhone users all of Apple Private Relay / Browsing tools are a VPN ).  ( Android phones - DNS changers are a VPN )

And after all of this it is still easier to manage the Hub via its menus !