Menu
Reply
Highlighted
  • 65
  • 0
  • 5
On our wavelength
202 Views
Message 1 of 10
Flag for a moderator

Using a Load Balance Router, no DHCP/WAN connection with SuperHub

Hello

I have a TP-Link Load Balance Router TL-R480T+ to use with my VM connection and a BT connection.

They are simple enough to use and are almost plug and play with very little configuration. Unfortunately the SuperHub doesn't want to play nicely and I'm having issues getting a WAN connection.

Fortunately the BT HomeHub works absolutely fine and I'm able to get a WAN IP and DHCP working fine.

I want the VM connection to be primary as it is a faster connection then to auto switch over to the BT if the VM was to lose connectivity.

Does anyone have any idea's why the SH doesn't want to pass on the WAN information on to the TP-Link? I have tried changing all sorts of configuration on the SH, modem mode, normal mode, firewall off, port scan detection off, IP flood detection, UPnP on and off but nothing makes a difference. With the BT HH it worked straight away without changing any settings.

Not sure what else to try, technically putting it in modem mode should allow the Load Bearing router to see the WAN address like it would with any other 3rd party router. If in modem mode, is DHCP disabled? I have left it in normal mode with DHCP working on all other devices, but as soon as I connect the router I don't get an address. Is the issue DHCP not giving the TP-Link an IP address with the correct subnet and gateway address? DHCP should be responding to any requests and assigning an address, but doesn't seem to like the TP-Link. Any advice would be greatly appreciated.

SuperHub no WAN connection, stays disconnected and fails to get WAN information. LAN Port 1 on the SH is connected to the WAN Port 1 on the router with connectivity lights.

SuperHub no WAN informationSuperHub no WAN information

BT HomeHub WAN connection successful and the internet works when routed through the failover connection (WAN2).HomeHub WAN connection successfulHomeHub WAN connection successful

thank you.

0 Kudos
Reply
Highlighted
  • 17.22K
  • 1.82K
  • 2.98K
Very Insightful Person
Very Insightful Person
187 Views
Message 2 of 10
Flag for a moderator
Helpful Answer

Re: Using a Load Balance Router, no DHCP/WAN connection with SuperHub

I dont know that router and not sure that this will help, but the standard procedure for connecting a 3d party router to a VM Hub is below - try it and see if it helps.
--------------------------------------------------------

Disconnect all cables from your Router and unplug it. Put the VM hub into modem mode (see VM website for details) and wait for the base light to turn magenta. Once it’s in modem mode, the VM hub must then be powered off. Then, set up your own router with the WAN port set to be in DHCP mode, it may be pre-set that way anyway. Make sure it’s fully initialised (leave 5 min) and then put in the WAN cable to the VM hub. Now power up the VM hub and you should get a connection. This order only needs to be done the first time you connect your own router to the VM hub.

--------------------
John
--------------------

My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
Highlighted
  • 31.3K
  • 1.62K
  • 5.47K
Very Insightful Person
Very Insightful Person
181 Views
Message 3 of 10
Flag for a moderator

Re: Using a Load Balance Router, no DHCP/WAN connection with SuperHub

i'd be looking towards the vlan. the hub is not vlan aware.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Highlighted
  • 14.72K
  • 620
  • 1.42K
Alessandro Volta
170 Views
Message 4 of 10
Flag for a moderator
Helpful Answer

Re: Using a Load Balance Router, no DHCP/WAN connection with SuperHub

If the VLAN is untag it should work.

The hub may not like the fact that the TL-R480T+ only has 100Mb ports

---------------------------------------------------------------
Highlighted
  • 65
  • 0
  • 5
On our wavelength
126 Views
Message 5 of 10
Flag for a moderator

Re: Using a Load Balance Router, no DHCP/WAN connection with SuperHub

Hi all

 

Thank you for your quick replies, I'm am trying a few things from your suggestions, firstly, no harm in doing a full reset, will check once it's complete. If not then I will attempt JBrennand's modem mode suggestion. 

 

Also for the other questions, the VLAN's on the TP link are set to untagged, also the router works fine when plugged in to a LAN port, though it's not using a WAN connection, I can still browse to the GUI so something is definitely blocking the WAN config.

 

thanks

0 Kudos
Reply
Highlighted
  • 1.41K
  • 200
  • 666
Very Insightful Person
Very Insightful Person
119 Views
Message 6 of 10
Flag for a moderator
Helpful Answer

Re: Using a Load Balance Router, no DHCP/WAN connection with SuperHub

I can see two potential problems looming here. What I would be tempted to do is to disconnect the BT HomeHub for now and just concentrate on the VM side, put the VM Hub into modem mode and go through the above procedure as stated by @jbrennand and see if the Hub passes through a public IP address to the TP-Link - there can sometimes be a bit of a knack to getting it working. If that is successful then connect the BT Homehub and see if that will work as well.

If the VM Hub is in router mode, then the problem you have is that the default LAN side subnet of the TP-Link is 192.168.0.0/24 which is the same as the VM Hub- effectively you are trying to get the same subnet on both sides of a router and that just won't work. Like you said, it should be simple plug and play but this does often have the potential to turn round and bite you very hard! If the VM Hub is in modem mode, then this isn't an issue - in router mode though you will first have to change the TP-Link's LAN subnet to something else, and not 192.168.1.0 as that what the BT system is using.

As an aside, I'm fairly sure you can't put the BT HomeHub into a PPoA passthrough mode so you are going to be stuck with double-NAT on that WAN 2 interface unless you replace the HomeHub with something else that does let you do pass through. It's not the end of the world though - it just won't be quite as elegant a solution as if you could get proper public IP addresses on both WAN interfaces.

Highlighted
  • 65
  • 0
  • 5
On our wavelength
77 Views
Message 7 of 10
Flag for a moderator

Re: Using a Load Balance Router, no DHCP/WAN connection with SuperHub

Hi all

 

Sorry for the late reply, I finally tried a few things with the VLAN, resetting the SH and eventually put it back in to modem mode and followed jbrennand's advice following a very specific routine and at first it did't auto connect on the WAN1 page, clicked connect manually and bingo! Got a WAN IP, subnet, gateway and DNS, I then connected the BT up again in to WAN2 and let it connect as usual, everything seems to be working fine now. The SH is set as primary and if the connection goes down (which it does far too often) the BT will kick in and take over, though unfortunately it's very slow but at least I'll have some sort of connection. I then have the TP Link connected to another wifi mesh router which then has it's own DHCP to connect all devices in the house to.

 

I will eventually replace the TP link with a gigabit version so that I'm not bottlenecked.

 

I will be giving Kudos to everyone who responded to my post!

 

Thank you.

0 Kudos
Reply
Highlighted
  • 31.3K
  • 1.62K
  • 5.47K
Very Insightful Person
Very Insightful Person
52 Views
Message 8 of 10
Flag for a moderator

Re: Using a Load Balance Router, no DHCP/WAN connection with SuperHub

another idea if the BT is slow. Have you thought about using a 4g connection for your backup. you can get an unlimited data plan for about £20 from some providers.
Might be cheaper than the BT line and may even be faster

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
Highlighted
  • 11.36K
  • 888
  • 1.45K
Alessandro Volta
47 Views
Message 9 of 10
Flag for a moderator

Re: Using a Load Balance Router, no DHCP/WAN connection with SuperHub

I use one of >> these << to switch between my BT & VM lines.

It is a manual switch but changes over within 5 or 6 seconds.

***********************************************************************************************************************************

Mike Robinson
Retired Aircraft Engineer & Computer Based Training and Learning Designer for many of the world's Military Arms.


My Broadband Ping - 26_Aug_2020

0 Kudos
Reply
Highlighted
  • 31.3K
  • 1.62K
  • 5.47K
Very Insightful Person
Very Insightful Person
35 Views
Message 10 of 10
Flag for a moderator

Re: Using a Load Balance Router, no DHCP/WAN connection with SuperHub

for that price i'd get an edgerouter x for double that cost 🙂

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply