Showing results for 
Search instead for 
Did you mean: 

Terrible WiFi and customer service

Joining in

We moved in march and had virgin scheduled to install. It took them over a month to do so

Then a month or two after my internet connection kept dropping out while attempting to wfh

I contacted customer service only to be told I need to double my monthly payment to upgrade our WiFi as we "have too many devices" (never had this issue at sky). The woman on the phone was not listening when I said I don't have an ethernet port on my laptop so can't use that and it doesn't help my mobile phone either. Despite me sitting in the same room as the router, my signal kept dropping out 

We disconnected some devices and upped our speed in the hopes it would rectify the problem. It did not

I then recontact customer service and got offered "pods" (which are doing nothing) only for me to discover they have extended my contract by doing so, despite me being desperate to leave

I have had to disconnect from the WiFi just to post this as it couldn't cope with the webpage 


Very Insightful Person
Very Insightful Person

What Hub model is it?

What is the connection like on a device connected to the Hub on an ethernet cable ?

Try this first.  Let us know if it works - if not there are other things you can try.

Go into the Hub’s settings. Type in  into your web browser’s url box and login with settings password on the Hub's base sticker (or your own if you changed it). Then in Advanced>wireless signal >smart wifi - tick the disable “channel optimisation” box or the“Smart Wifi” box and save settings.  May be different pathways and wording on the 3 Hub types This (message 2) is for a Hub3…

Then, go to advanced>wireless signal>security, rename the 2.4 & 5 GHz network ssid's.  Just type over to change 'em to whatever you like and something that will differentiate them (e.g - Parrers_2 & Parrers_5) Try to avoid spaces and periods in the SSID names as they can cause issues with certain devices. Use the same password for simplicity,  Then, apply settings and restart the Hub.  Your 2 wifi networks will now be clearly separated - and you can then select the network you want each device to connect to… individually from the "available networks" list on each of your devices. 

Note all your wifi devices will need re-connecting to the new SSID's and passwords.
All things being equal, 5 GHz is always better/faster and subject to less congestion/interference (and is better for iDevice speeds than the 2.4 one - although the 2.4 one has the better "range" and will be needed when the 5 GHz drops out of range and some older/cheaper/dumber or “specialised” devices can only use this one. 

You should also use a wifi analyser App (or Airport Utility on iOS) to check which 2.4 channels are being heavily used around you and move yours to one of numbers 1,6,11 that is least so, but it wont help if there is other interference.

See if these changes help - you will lose any “seamless roaming” benefits but it may not matter and you can always change the settings back by doing a " pinhole factory reset " if you prefer the way it was - or it doesn’t help.


I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's & TP-Link Archer C64 WAP. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

We have the main connection then the ext connection too. I've disabled channel optimisation too 

Alessandro Volta

If your unhappy with VM wifi you can get your own wifi router with 1Gb ports put hub in modem mode


Thanks for your post on our Community Forums @Parrers, and a very warm welcome to you!

I'm terribly sorry to hear of the poor experience you've had with the connection, and with our customer service team.

Can you please confirm if you're able to address the points/questions raised by @jbrennand for us?

Have you possibly also attempted to relocate the Wi-Fi pod you have connected to the services?

It may be worth clicking this link to help you combat the Wi-Fi issues you’re experiencing