Showing results for 
Search instead for 
Did you mean: 

Teams call constantly freeze, Jitter and Latency very high from Hub

Joining in

I have never had issues with any other of my broadband providers for Teams calls but with Virgin Media I am constantly apologising and nearly always end up using my phone hotspot mid call in the last few weeks.

Using the Connect App, all the Jitter and Latency seem to come from the hub and not the Wifi.

Jitter is between 150 - 200ms over the last hour and a half in 7 tests and Latency is showing as over 10,000ms in each test which seems bizarrely high.

I was looking at how to access web chat to report this but cannot find the link on this site.

Is there anything that can be done or is this going to be a constant feature of Virgin?




Joining in


This is what I got from a quick test on Think Broadband. Packets lost and terrible latency.


The VM Connect app strikes again - a year on and it is still not fixed !

10783 ms = 10.783 seconds - did that not appear quite odd ?
The right figure is 10.783 ms which is very decent.

As for Jitter the correction factor last time we looked was divide by about 200 making Jitter minimal too.

MS Teams is the most complained about platform of all, gripes come often but for BT MeetMe, Zoom., Skype, WhatApp & Cisco WebEx near to silence. What to conclude !

The latency looked bizarre as I said in my original post but I must admit that I didn't think that it would be some well know App error that never got fixed, that just seems a bit casual.

Teams has always been very reliable for me, it is just the last two weeks that I am suffering and I am the only one on the call with freezing.

I was ready to use a spare Wifi router and the Hub3 in modem mode but the Connect App made me think this was an issue on the other side of the hub.

I might try an alternative Wifi solution and see if that helps.


Community elder

BQM shows a clear issue with either your line or the local area.


BQM is super colourful, but I've yet to grasp where the events occurred.


Try Teams with a network cable, the half duplex nature of WI-Fi can affect application like Teams where a constant data stream runs in both directions at all times during the call.

Joining in

I was ready to use a spare Wifi router and the Hub3 in modem mode but the Connect App made me think this was an issue on the other side of the hub.

Hello Soundy,


Thanks for taking the time to post in regards to your connection and wireless issues, we appreciate you raising this via the forums.


From checking the connection we can see it is averaging 137mbps download and 21mbps upload, the latency is showing 10.25ms and jitter at 0.82ms which all look to be fine. One issue seems to be disconnections occurring at the roughly the same time each day, are you regularly rebooting the Hub around 5pm each evening?


Have you had chance to try the hub in modem mode with a third party router?




On the 15th I rebooted and on the 17th I had to turn the electricity off to fit something unrelated, other than that I don't reboot.

I haven't tried the alternative Wifi yet as it is only a problem during the week on work calls so will hopefully test this week.

The download speed are fantastic compared to my previous ADSL connection, it is just the Teams issue which I  never had previously with of my providers despite being a heavy Teams use the last three years and on Wi-Fi.

If the issue is on this side of the Hub then I am sure I can fix it.