Showing results for 
Search instead for 
Did you mean: 

Superhub 5 WiFi Not Connecting After Changing SSID

Tuning in

Hi all,

I am having a strange issue with my new hub 5 and customer support are not very helpful so thought I would see if anyone else is having a similar issue. 

My new hub 5 arrived yesterday after complaints with my hub 4 and wanting the ability to connect my devices with Wifi6. Everything connected fine and within 10 minutes or so I was getting a wireless connection speed to my phone on Wifi6 at 600MB which was excellent and exactly what I wanted.

I then logged into my hub and changed the SSID and password to match what I had before as all my smart devices are configured to that. Once the hub rebooted I can see the SSID being broadcast but only about 30% of my devices are able to connect to this. All laptops and phones are saying either 'The Password Is Incorrect' , 'Failed To Connect' or 'Could Not Obtain IP address'

The connection details have been verified and must be correct as some devices are connecting, these appear to be older smart plugs on 2.4Ghz but there are 1 or 2 connecting on 5Ghz. I have tried changing the security protocal but this makes no difference. 

VM said yesterday to leave the equipment off for 4 hours and call back again if its still not working, but i think im just being fobbed off as there is nothing wrong with the actual Internet connection.

For now I have put this in Modem mode and reconnected my mesh to get the house back up and running. I ideally want to get rid of the mesh as there is bandwidth drop between the units as I dont have an ethernet backhaul.

Any ideas?


Tuning in

I have the exact same problem too. After changing SSID you can connect but it gives no internet at all. Shambles if you ask me.  Around 35 devices at this rate i'll have to reconnect manually 



These are known Wi-Fi / DHCP issues of the Hub 5 and VM remain silent on the matter.
A Hub 5 in modem more and a 3rd party router would solve the issues at a stroke.

I gave up the the hub in the end, stuck it in Modem mode and bought a TP Link Deco PX50 which uses a power line backhaul and no problems with that whatsoever now. 

As soon as this was up and running, every device connected to it in 2.4 and 5GHz almost instantly.

Yep, exactly what I did and no problems since.

Fibre optic

Hi Virgin

I have this issue. But also found the cause and a workaround.

But when is the root cause going to be fixed please?

Fyi your engineer offered to rename the SSID for me but we missed the initial setup page and we encountered this issue when renaming in the detailed setup instead... Spent 45 minutes renaming, fail, device reset, try again, fail, rinse repeat.


In the end he left with default settings and I found a workaround.

You need rename SSID on the initial setup wizard page after yet another factory reset. And then after that you can rename the SSID again in the detailed page say if you want to split the 2g and 5g network like I did.

Do NOT rename in the detailed WiFi detailed settings which is clearly broken until you've named it at least once in the initial setup wizard.

So while I have workaround the point is that this is a real bug and being silent on it and not even telling your engineers is wasting their time, and presumably costing you money too.





2020 Tivo-scaling bug (nearly resolved)

Virgin-TV-V6 Video-Output-Settings

I have the same problem. After changing SSID I can't connect the devices to Internet. Virgin any updates?


Did you try the workaround set out in the previous post ?

Fibre optic

I had this sooooo many times with my hub 5s (on the second one now). As above the page for maintiaing SSID's seems to really mess the modem up. As above realaibly i is best to pinhole reset and start again and change it in the initial set up and them split after. Also I did find that sometimes though if you split them it will not pick up the 5ghz band properly or will say no internet. Sometimes a power off and restart solved it (not a reboot from within the interface). Hope this may help a little.

My Broadband Ping - Virgin Modem Mode

I've given up and renamed mine back to the original SSID as I've found that after rebooting I can no-longer connect to wifi at all with dynamic IP addresses (DHCP server issues).

Even while doing that I could see bugs a-plenty.

The first attempt to rename both 2G and 5G (I had them split) back to out-of-the-box names at the same time didn't work at all.

The second attempt to rename first only the 2G worked; but when I went to rename the 5G it didn't and was still on the old (renamed) name.

Then, while the SSID were both the same as the out-of-the-box I tried renaming back to how I had it with -2 and -5 Suffix.

The router again applied that edit to the 2G but not the 5G.  While configured like that the router would not allow connection to the 2G unless via Static IP, but would still allow connection via the dynamic IP address on the 5G that was still named as per out-of-the-box.

I then remembered this is the same as the original issue and the fix for that was full factory reset and to rename the SSID during the initial Wizard, because the renaming in the regular menus is broken (see earlier posts above)




2020 Tivo-scaling bug (nearly resolved)

Virgin-TV-V6 Video-Output-Settings

Fibre optic

My thought is that there's three issues and there's some incorrect hard-coding within the router dependent on the original SSID, and then some inter-dependencies between the SSID and DHCP somehow as follows:

  1. renaming SSID via the menus is totally broken; it breaks DHCP
  2. renaming SSID during the original setup Wizard works and survives reboots.  BUT...
  3. Eventually on some reboot, maybe weeks later (say if following support procedures to correct WAN connectivity issues) the hub does something to break SSID and DHCP again. 
    Maybe hub is applying a firmware update or some other change that tries to set SSID back to the out-of-the-box setting but SSID and as broadcast and in GUI is still as you've named it.
  4. once #3 breaks any attempt to resolve DHCP by renaming SSID back and forth fails unless you set back to the out-of-the-box setting, or reset and rename via the Wizard per step #2.


My hypothesis is there's another SSID behind the scenes being hard-coded somewhere in the DHCP logic to the out-of-the-box value or that which you've set via Wizard; but then that hidden SSID is reset and broken either via subsequent amendments in the GUI or Virgin firmware update.

Basically VM need to fix renaming of SSID and DHCP




2020 Tivo-scaling bug (nearly resolved)

Virgin-TV-V6 Video-Output-Settings