• 3
  • 0
  • 0
Tuning in
Message 1 of 7
Flag for a moderator

Speed drop from 200 to under 50

Hi There, 

Been having an issue with my Virgin speed in Area 21. For the past 2 weeks nearly my speed has dropped dramatically. I contacted the Virgin for help and we went through the steps of restarting PC/Router, factory resetting and monitoring. Speed did not increase so an engineer was booked for Mon 15th Oct as no fault in the area. 

On the day the engineer was coming out my speed went back up to 200 so I cancelled the engineer...How silly of me!

I have been away for a couple days and now my speed has dropped again. Have done all the same tests as before but to no avail. 

PC is running off Ethernet connection.

Below is the Downstream and error log from router. Upload is perfectly fine. 

Channel Frequency (Hz) Power (dBmV) SNR (dB) Modulation Channel ID

1298750000-0.738256 qam21
2442750000-1.738256 qam30
3434750000-1.238256 qam29
4426750000-1.538256 qam28
5418750000-1.238256 qam27
6410750000-1.238256 qam26
7402750000-1.238256 qam25
8322750000-138256 qam24
9314750000-138256 qam23
10306750000-0.538256 qam22
11290750000-0.538256 qam20
12282750000-0.536256 qam19
13274750000-0.435256 qam18
14266750000-0.534256 qam17
15258750000-0.433256 qam16
16250750000-0.533256 qam15
17242750000-0.537256 qam14
18234750000-0.536256 qam13
19226750000-0.536256 qam12
20218750000-0.535256 qam11
21210750000-0.535256 qam10
22202750000036256 qam9
23194750000037256 qam8
241867500000.236256 qam7


Time Priority Description
2018-10-13 17:23:09.00Warning!RCS Partial Service;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-13 17:29:26.00Warning!Lost MDD Timeout;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-13 17:29:26.00Warning!RCS Partial Service;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-13 18:24:55.00Warning!Lost MDD Timeout;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-13 18:24:55.00Warning!RCS Partial Service;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-13 23:42:58.00Warning!Lost MDD Timeout;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-13 23:42:59.00Warning!RCS Partial Service;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-14 00:48:58.00Warning!Lost MDD Timeout;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-14 00:49:00.00Warning!RCS Partial Service;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-14 17:07:34.00Warning!Lost MDD Timeout;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-14 17:07:35.00Warning!RCS Partial Service;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-14 17:55:22.00Warning!Lost MDD Timeout;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-14 17:55:23.00Warning!RCS Partial Service;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-15 21:38:34.00criticalNo Ranging Response received - T3 time-out;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-17 17:27:06.00Warning!RCS Partial Service;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-17 18:17:59.00criticalNo Ranging Response received - T3 time-out;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-18 08:47:41.00Warning!Lost MDD Timeout;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
1970-01-01 00:01:22.00ErrorMissing Mandatory MDD TLV on primary DS Channel;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
1970-01-01 00:01:39.00criticalNo Ranging Response received - T3 time-out;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;
2018-10-18 20:30:49.00Warning!RCS Partial Service;CM-MAC=**:**:**:**:**:**;CMTS-MAC=**:**:**:**:**:**;CM-QOS=1.1;CM-VER=3.0;

0 Kudos
  • 19.22K
  • 1.68K
  • 4.22K
Message 2 of 7
Flag for a moderator

Re: Speed drop from 200 to under 50

Looks like an issue with the downstream signal to noise ratio on channels 15 & 16 right on border line, so looks like a tech visit is needed, can call faults and have rearranged or can wait a few days for forum admins to arrange

If someone's helped you out say thanks by clicking on the thumbs up on kudos. If someone's solved your problem, why not mark their message as an Accepted Solution, but only do this once issue has been resolved.
  • 5.3K
  • 105
  • 1
Moderator (Retired) Ty_S
Moderator (Retired)
Message 3 of 7
Flag for a moderator

Re: Speed drop from 200 to under 50

Hi icewolf250

Welcome to the community and I'm sorry to hear of the slow speeds you've been experiencing. I've run some checks on your connection and everything is looking great now. Are you still experiencing slow speeds? If so are you connected wireless or via ethernet?

Speak soon

The do's and don'ts. Keep the community welcoming for all. Follow the house rules

  • 3
  • 0
  • 0
Tuning in
Message 4 of 7
Flag for a moderator

Re: Speed drop from 200 to under 50

Hi There 

Thank you for reply. Sorry for getting back late, Been away. Speed is still up and down. Some days its good others it drops low. Right now im on 146mbps

Connection is via ethernet. 

Kind Regards


0 Kudos
  • 9.07K
  • 248
  • 545
Forum Team (Retired) Nat_J
Forum Team (Retired)
Message 5 of 7
Flag for a moderator
Helpful Answer

Re: Speed drop from 200 to under 50

Sorry to hear this icewolf250,


Many thanks for updating the thread.


I've checked things from this end and everything appears to be within range.


How have things been since posting?



Who's who? Find out more about our community members. Good folk to know

0 Kudos
  • 3
  • 0
  • 0
Tuning in
Message 6 of 7
Flag for a moderator

Re: Speed drop from 200 to under 50

Hi There

I apologise for my late reply again. Things have been good with the speed since posting. I do get the occasional drop to lower speeds but I gather this is just throttling during busy times.


I do however think something is wrong with my Hub3. Quite often the RJ45 ports just stop working and appear to stop giving out DHCP. All wired devices therefore do not connect but phones on Wifi still work. Problem is only solved by rebooting router.  What are the chances/cost of a replacement?

0 Kudos
  • 12.75K
  • 399
  • 730
Forum Team (Retired) Heather_J
Forum Team (Retired)
Message 7 of 7
Flag for a moderator

Re: Speed drop from 200 to under 50

Hi icewolf250, 

Thanks for staying in touch 🙂

Sorry to hear that your Ethernet ports are intermittently not working. With regards to getting a replacement, we can do this via online chat. 

Catch you soon, 

Take care. 


Tech fan? Have you read our Digital life blog yet? Check it out

0 Kudos