Menu
Reply
vJaCkHz
  • 18
  • 0
  • 1
Tuning in
290 Views
Message 1 of 10
Flag for a moderator

Slow broadband after speed upgrade

So last week (02/12/2020) I upgraded from M200 broadband to M500 broadband, and i'm now averaging wired speeds of 90Mbps, instead of the 220Mbps I was getting before the upgrade.

I've used Virgin's online chat service twice now to try and get it sorted, both times messaging for over 5 hours without a solution, and transferred to another adviser that never showed up...

I have my Hub 3.0 in Modem mode, which is connected via ethernet to a TP link gigabit router, which is then connected via ethernet to my PC that has a gigabit internal NIC. I've tried every suggestion including using the Hub in router mode and connecting directly via ethernet to my PC but i'm still getting the same speeds. I also use a cat6 ethernet cable so that's not the issue either.

Strangely I reset my router a couple of times, forgot the network on my phone before re-connecting, and I did manage to get 450+Mbps download speed a couple of times if I stood right next to the router. However I would only get this speed on the first test, and any tests after that would go back below 80Mbps. 

Any help with this would be much appreciated.

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.93K
Alessandro Volta
273 Views
Message 2 of 10
Flag for a moderator

Re: Slow broadband after speed upgrade

What speeds do you get at >> speedtest.net << with a direct connection using a Cat 5E or better ethernet cable between the Hub in Router Mode and a 1Gbs capable Pc/Mac/Chromebook and no other devices connected ?

then 

Can you Login to the Hub Settings and navigate to the Connected Devices page - what is the reported 'connection speed’ for the ethernet cable connected device you used for the speed test ?


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
vJaCkHz
  • 18
  • 0
  • 1
Tuning in
265 Views
Message 3 of 10
Flag for a moderator

Re: Slow broadband after speed upgrade

Hi Mike,

Thanks for the reply. As stated in my post, using a cat6 cable with a direct connection to my PC from the hub in router mode I am getting around 90Mbps download speed.

Logging in to the Connected Devices page I can see that the reported connection speed for the ethernet cable is being limited to 100mbps. This would make you think the issue is with the cable but I know that is not the case as this has only been a problem since upgrading, and I was achieving speeds of 220mbps with the same cable before the upgrade.

 

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.93K
Alessandro Volta
257 Views
Message 4 of 10
Flag for a moderator

Re: Slow broadband after speed upgrade


@vJaCkHz wrote:

Hi Mike,

Thanks for the reply. As stated in my post, using a cat6 cable with a direct connection to my PC from the hub in router mode I am getting around 90Mbps download speed.

Logging in to the Connected Devices page I can see that the reported connection speed for the ethernet cable is being limited to 100mbps. This would make you think the issue is with the cable but I know that is not the case as this has only been a problem since upgrading, and I was achieving speeds of 220mbps with the same cable before the upgrade.


Cables do go wrong though, that is one of the reasons that that they are sold.

If you are confident that the cable is good can you check the 'Link Speed' in the device settings and get back to us.


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
vJaCkHz
  • 18
  • 0
  • 1
Tuning in
248 Views
Message 5 of 10
Flag for a moderator

Re: Slow broadband after speed upgrade

That's very true - I just find it highly unlikely that the cable went bad at the same time I got upgraded, when my speeds were fine the day before.

I've checked the link speed and that is also saying the cable is being limited to 100mbps.

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.93K
Alessandro Volta
244 Views
Message 6 of 10
Flag for a moderator

Re: Slow broadband after speed upgrade

Have you got a different Cat 5e or better cable to try ?


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
vJaCkHz
  • 18
  • 0
  • 1
Tuning in
242 Views
Message 7 of 10
Flag for a moderator

Re: Slow broadband after speed upgrade

I do, but the issue is my current cable that is plugged into my PC is routed from downstairs and outside the house, and then back through a hole into my bedroom upstairs, so it's probably a good 100ft of cabling to reach my PC.

Since my PC is the only device capable of gigabit speeds, I would have to move it downstairs to try it with a different cable, but I suppose that's the only option I have.

0 Kudos
Reply
MikeRobbo
  • 15.27K
  • 1.17K
  • 1.93K
Alessandro Volta
238 Views
Message 8 of 10
Flag for a moderator

Re: Slow broadband after speed upgrade

One of the trials of troubleshooting I'm afraid.

What does it say for the NIC in the PC ?

Link-Speed

 


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply
vJaCkHz
  • 18
  • 0
  • 1
Tuning in
231 Views
Message 9 of 10
Flag for a moderator

Re: Slow broadband after speed upgrade

Apologies it's not a NIC I have in my PC, just a gigabit capable ethernet port. Under 'speed and duplex' in device manager for that port, the value is 'Auto Negotiation'.

I've also just noticed that while the hub is in modem mode and connected to my router, and my PC connected to that, the speed of the ethernet port is 1Gbps. But if I plug my PC directly into the hub in router mode, the same port drops down to 100mbps.

0 Kudos
Reply
vJaCkHz
  • 18
  • 0
  • 1
Tuning in
103 Views
Message 10 of 10
Flag for a moderator

Re: Slow broadband after speed upgrade

Turns out a faulty cable was the issue after all... Just a very strange coincidence that it happened at the same time as my upgrade!

Thanks for the help 🙂
0 Kudos
Reply