Menu
Reply
  • 10
  • 0
  • 1
DCrossland
Tuning in
2,400 Views
Message 1 of 28
Flag for a moderator

Slow WiFi on iPhone

Hi, over the past couple of months I have experienced very slow WiFi when using my iPhone 7, all the other devices in my house work fine with no issues but mine and my girlfriends iPhones appear to have intermittent connection. I have tried the usual things, ensuring the router isn’t obstructed, turning off anything that could be interrupting the signal and even run some cables to some devices so the WiFi isn’t as busy but still my connect seems hit and miss. When my connection seems to drop I still have full signal showing on the phone, when I do a speed test it’s inconclusive, sometimes it won’t let me do a test at all and appears to have no internet and other times it does a test and starts slow 2-10mbps and builds up to the usual 100-200mbps yet my phone still struggles loading simple images or videos on the likes of YouTube/instagram. Please can anyone help or has anyone else experienced this before?

Thanks in advance 

0 Kudos
Reply
  • 5.47K
  • 427
  • 917
Tudor
Superstar
2,396 Views
Message 2 of 28
Flag for a moderator

Re: Slow WiFi on iPhone

What hub do you have?


There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal
0 Kudos
Reply
  • 10
  • 0
  • 1
DCrossland
Tuning in
2,378 Views
Message 3 of 28
Flag for a moderator

Re: Slow WiFi on iPhone

I have the Hub 3.0

thanks

0 Kudos
Reply
  • 10
  • 0
  • 1
DCrossland
Tuning in
2,350 Views
Message 4 of 28
Flag for a moderator

Re: Slow WiFi on iPhone

I have followed advice from other posts and change the SSID of my 2.4 and 5 channels unfortunately I’m still having issues. I’ve just run a speed test on my iPhone which brought back 4000ms before failing and at the same time I run one on my iPad which came back with 9ms with a 198mbps download. The problem appears to lay between my iPhone and the router, any ideas?

my iPhone works perfect on other WiFi networks.

HELP!! Smiley Sad

0 Kudos
Reply
  • 5.3K
  • 105
  • 1
Moderator (Retired) Ty_S
Moderator (Retired)
2,323 Views
Message 5 of 28
Flag for a moderator

Re: Slow WiFi on iPhone

Hi DCrossland

 

I'm really sorry to hear that you've been experiencing slow speeds when using your phone.. I'll certainly look into this for you.

I've run some checks on your modem/network segment and can't see any issues affecting your hub that would cause this. Can you try changing the wireless channel and see if this improves things? How are results with devices connected via ethernet? 

Speak soon,

Ty


The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos
Reply
  • 1
  • 0
  • 2
jamesrpryor
Joining in
2,201 Views
Message 6 of 28
Flag for a moderator

Re: Slow WiFi on iPhone

I am having the exact same issue. Both my mum and I who use the same wifi have been experience almost no wifi on both our iPhones, despite sitting right next to the router. However our laptops are absolutely fine. 

I phoned Virgin who did a speed test (via my laptop) and could only tell me that my connection was fine, which is infuriating because its not.

I use the 5g wifi, Ive rebooted the modem, Ive reset the network on my phone. Nothing seems to work. 

Would be useful for Virgin to look into the issue further rather than just telling us our connections are fine because of laptop speeds and therefore no issue on their end.

  • 10
  • 0
  • 1
DCrossland
Tuning in
2,180 Views
Message 7 of 28
Flag for a moderator

Re: Slow WiFi on iPhone

It is definitely something that needs looking into properly, I’m still experiencing these issues so end up using more and more of my 4G data, I’ve tried everything but the WiFi seems totally hit and miss. I can run a test on my phone that shows I have 200mbps connection but an Instagram or YouTube video will hardly load if at all. Then I run a test 30 seconds later and the test fails to even start.

Come on Virgin Media there must be a solution to this issue... help?!

 

  • 10
  • 0
  • 1
DCrossland
Tuning in
2,177 Views
Message 8 of 28
Flag for a moderator

Re: Slow WiFi on iPhone

Tried to change the wireless channel, tried full factory reset and reset my phone to factory settings.

I’ve also change the 2g and 5g so it only stays connect to one rather than switching and still it’s hit and miss.

Ethernet connections appear to be fine it’s the WiFi connecting to iPhones that is the issue.

I’m at a loss, help??

 

 

0 Kudos
Reply
  • 7.32K
  • 761
  • 1.14K
jbrennand
Legend
2,166 Views
Message 9 of 28
Flag for a moderator

Re: Slow WiFi on iPhone


@DCrossland wrote:

Tried to change the wireless channel, tried full factory reset and reset my phone to factory settings.

I’ve also change the 2g and 5g so it only stays connect to one rather than switching and still it’s hit and miss.

Ethernet connections appear to be fine it’s the WiFi connecting to iPhones that is the issue.

I’m at a loss, help??

 


This is odd for a Hub3 (sure its a hub3 Smiley Happy) but normal for SH2.  Do you have other devices that are connected by wifi and are they performing satisfactorily ?  Also do you have a friend/neighbour with a similar model/iOS of iPhone you can ask to see whether they can connect to your wifi network  ok?  If they can then its a setting on the iPhone that needs changing - f they can't too then its a Hub issue.

You tried this ?

https://community.virginmedia.com/t5/Networking-and-WiFi/Potential-FIX-for-WiFi-Disconnections/td-p/...

 


--------------------
Services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
  • 10
  • 0
  • 1
DCrossland
Tuning in
2,134 Views
Message 10 of 28
Flag for a moderator

Re: Slow WiFi on iPhone

Yeah it’s definitely a HUB3, I replaced my SH2 last Christmas due to other issues and for a few months it seems to be fine until this issue developed.

Unfortunately I don’t have a neighbour with an iPhone but I do have an iPad running the same iOS, I can do a speed check on that which shows 210mbps and a speed check on my iPhone shows 40mbps, however when trying to load a website the iphone still struggles to load pictures. My girlfriend also has an iPhone 7 and experiences the same issues but at different times?! Hers can be working fine while mine not and vice versa.

I’m really struggling to narrow down what the problem is which as you can imagine is very frustrating.

I haven’t tried to turn off the ‘Smart Wifi’ before but just done it now so will update in afew days with the results

Thanks for the help

 

 

0 Kudos
Reply