• 34
  • 0
  • 0
On our wavelength
Message 1 of 4
Flag for a moderator

Slow WiFi, again.

I was having problems with the wifi reception in my home office.
The problem was resolved when I talked to a Virgin Media representative on the phone.
He split my wifi so that I had a 5g and 2.4g on the same hub (HUb 4).
So on available networks I had, for example, VMmywifi 2.4 and VMmywifi. This worked perfectly and my download speed went from 3-5Mbs to 35Mbps.
A week ago we had a power outage and lost all Virgin Media services, including our landline (on the old BT network. Not via the hub.). The new VMmywifi2.4 disappeared. I checked my hub and the 5Ghz and 2.4Ghz are both enabled but my download speed is now 3Mbs again.
How do I get the hub 'split' again, and restore the VMmywifi2.4 back?

Tags (2)
0 Kudos
  • 8.14K
  • 899
  • 2.68K
Very Insightful Person
Very Insightful Person
Message 2 of 4
Flag for a moderator

Re: Slow WiFi, again.

Sign into Hub and then:

  • select Advanced settings > Wireless > Security
  • amend Wi-Fi network names
  • select Apply changes

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more
Have I helped? Click helpful.jpeg Mark as Helpful Answer and solved, or use thanks.jpeg Kudos to say thanks

  • 15.86K
  • 2.1K
  • 4.98K
Very Insightful Person
Very Insightful Person
Message 3 of 4
Flag for a moderator

Re: Slow WiFi, again.

Hi @Macflame 

Open a browser and log into your hub - using the SSID and wifi settings password printed on a sticker on your hub

Then navigate to the following settings so you can differentiate between the signals.

Advanced Settings > Wireless > Wireless Signal > click on Disable Channel Optimization  at the bottom then  click on Apply Changes. 

Now go to Advanced Settings > Wireless > Security > Edit the end of the 2.4GHz Channel name - For example if it's VMmywifi change it to VMmywifi 2.4 

You don't need to edit the name of the 5Ghz connection but if you want to then you could rename it to VMmywifi5 for example

You can leave the passwords the same as they are.  Then at the bottom click on Apply Changes. Then log out of the hub at the top of the page.

You will need to reconnect all you Wi-Fi devices again, some will want to connect to 5Ghz and some to 2.4GHz and some will connect to either.


You could also do a search for an app such as wifi analyzer which tells you the strength of the channel you are connected on, and also shows other channels so you can decide if you want to change the channel number on your hub toone that's possibly less congested.

Advanced Settings > Wireless > Wireless Signal >  beneath both the 5Ghz and  2.4GHz sections click on the manual button, and in the drop down box click on the channel number you want to change it to, then scroll down and  click on Apply Changes.


The hub's now do have a habit of being automatically reset by the VM systems as they are now set up with combined bands which should search for and link to the strogest available signal.


I don't work for Virgin Media.

I'm a Very Insightful Person, I'm here to share knowledge. Learn more

Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks

The do's and don'ts. Keep the community welcoming for all. Follow the house rules
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali
Love, love and love, forever - Pele

  • 4.89K
  • 159
  • 336
Forum Team
Forum Team
Message 4 of 4
Flag for a moderator

Re: Slow WiFi, again.

Hi @Macflame,

Thank you for your post and welcome back to our community forums. We're here to help.

I'm really sorry to hear that you've been experiencing some Wi-Fi issues recently. Let us know if the advice offered by the other members of the community has helped at all, and if you need further assistance we can go from there.



Zach - Forum Team

New around here? To find out more about the Community check out our Getting Started guide

0 Kudos