Showing results for 
Search instead for 
Did you mean: 

Registering new Hub 5 on connect

Joining in

I've just upgraded my router from the 3 to the 5. Since doing this I'm now unable to set the new router up on the connect app. Any ideas?


Joining in

Hi! I received my Hub 5 yesterday and while it works fine the Connect app doesn't, well... Connect! I have tried the app on two phones and uninstalled and tried again . No joy.. I have made sure I am on the right connection, no VPN etc .


It takes VM back end systems some time to catch up to the change of Hub.
For now connect to the Hub 5 at and configure it using the menus.

Forum Team
Forum Team

Hey CBrewster, thank you for reaching out and a warm welcome to to the community.

We're sorry to hear you're having an issue with the Connect App recognising your hub. 

The first thing to be aware of is you need to be connected to your Home WiFi in order for the app to connect to the Hub. It won't allow the connection if you're on a Guest network, VPN or Mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that: 

For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. 

For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 

If this also fails then we currently have a known error with some of the data in our systems, that is causing the app to not recognise the Hub in a minority of instances. We are already investigating this as a high priority. 

Pop back and keep us posted. 



Matt - Forum Team

New around here?